4
$\begingroup$

I'm following this tutorial, and when I import the reference image I get a glitchy plane:

enter image description here

(the one on the right is the Image as Plane, while the one on the left is an Empty with an image)

I have made sure that the image, found online, was transparent, using Photoshop:

enter image description here

In trying to troubleshoot this, I have looked at this question, but it doesn't help me, as I can't reproduce the steps given in the answer.

Basically, I'm stuck looking for parameters for this object. There's nothing in the Object Data panel, I tweaked Viewport Alpha in the Material tab but still nothing...

$\endgroup$
  • $\begingroup$ can you upload the image in question? $\endgroup$ – cegaton Dec 24 '15 at 17:32
  • $\begingroup$ The question was solved, but just to answer your comment, it's the same image that the user who made the tutorial uses - one of the first results for the "palm tree" image search on Google: pngimg.com/upload/palm_tree_PNG2489.png $\endgroup$ – MicroMachine Dec 24 '15 at 22:45
3
$\begingroup$

When you click import images as planes and the file browser opens, in the lower right, under 'import images as planes', you need to check the use alpha checkbox, or you will get bizarre alpha junk. Why this isn't a default I have no idea.

As an alternative on the UV/image editor press N to bring up the options window and enable "Use Alpha"

$\endgroup$
  • $\begingroup$ Good to know, thanks! The answer of the question this is a duplicate of was really good as well. $\endgroup$ – MicroMachine Dec 24 '15 at 22:46
  • $\begingroup$ @photox blender does not flag or attempts to destroy anything... simply enabling alpha (when importing images as planes or on the UV/image editor) will fix transparency. i.stack.imgur.com/tHkyR.gif The image in question has RGB information on top of the Alpha. It's just a matter enabling so that blender uses it. For a detailed explanation on the issue read the comments on this post: blender.stackexchange.com/questions/21081/… no need to delete anything of reopen or use external software $\endgroup$ – cegaton Dec 25 '15 at 1:22
  • $\begingroup$ Ok, that works, open the properties panel in the uv editor and check 'use alpha' can be used after importing without alpha enabled. $\endgroup$ – photox Dec 25 '15 at 16:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.