2
$\begingroup$

I am doing an animation. The images I have attached show 2 different render layer view node results.

  1. Image one shows a cube on layer 1, and 2 icosphere on layer 2. I have layer 2 set to fast blur. I have to use transparent film and therefore I use the Alpha over nodes in composition.
  2. Image two shows a cube and 1 icosphere. Image 1 should not be showing 2 icospheres, as the left most one is behind the cube.

Image 2 is from the same render result, and is correcting showing only 1 icosphere. However, that icosphere should be blurred as it is on layer 2. It seems for whatever reason I can not have both the correct composition effect and also have every object's visibility render correctly. I can only either have everything work fine, with no composition, or composition with every emission object showing through every other object in the scene.

I am aware that masks would solve this problem, but because of the complicated setup of object materials and particles, masking produces these very strange and suddenly appearing artifacts. Material Indexing also produces odd artifacts and does not consistently effect the appropriate materials.

This is also a new problem, I did not have this issue in the last blender version. So, material indexing is out, masking is out, object indexing is out.

enter image description here

I want to use the compositor to blur certain layers, but every emission object in the scene shows through. It shows through as though it was on x-ray, regardless if it is behind another or inside another object. The first image is an example of this, the left icosphere is behind the cube, and should not be visible. That is the problem. Why is it visible when it shouldn't be?

$\endgroup$
  • 2
    $\begingroup$ Where is the cube? Would it be possible for you to upload this part of the scene to blend-exchange.giantcowfilms.com for a more in depth inspection of the settings? $\endgroup$ – Carlo Dec 23 '15 at 13:22
  • 1
    $\begingroup$ You have mentioned the compositor. Please place an image of the compositor nodes. By presenting the nodes you may see simplifications. Of course you can simplify the node image and scene image to protect confidential information. The [simplest] arrangement that fails would be interesting. You can also bold the word COMPLEX if you like for extra emphasis. On the other hand I find the find the problem description difficult to read. Suggestion. Rewrite the problem description in more paragraphs ... not more words. $\endgroup$ – atomicbezierslinger Dec 23 '15 at 14:17
  • 2
    $\begingroup$ @RichardBrockJr. usually when an question remains without an answer is because something about it is not clear. Instead of posting more comments please use the edit link (at the at the bottom left of your question: blender.stackexchange.com/posts/43539/edit) and clarify what it is you are after. Do not resubmit the question as a separate post. $\endgroup$ – cegaton Dec 24 '15 at 6:48
1
$\begingroup$

It's not a bug, it's the expected behaviour, what you need is to use the "Z combine node". In my example I've set layer 1 into render layer1 only, and L 2 into RL 2. As the blur increases the size of the icosphere, i've added a dilate/erode node on the Z channel of render layer 2.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.