4
$\begingroup$

I'm working with some text objects for some motion graphics. However, the edges come are really rough:

enter image description here

Initially I figured it was just caused by lower-res rendering in the 3D view, however, it also shows up when I render it out at 100%:

enter image description here

I'm using the Cycles render engine, rendering using CUDA on a GTX 750 Ti, and here's the node layout for that text:

enter image description here

Is there any way I can improve the quality of the letters?

EDIT As requested by Todd McIntosh

Wireframe:

enter image description here

$\endgroup$
9
  • $\begingroup$ I think you are talking about AntiAliasing here? $\endgroup$ – zeffii Dec 22 '15 at 23:09
  • $\begingroup$ @zeffii Yes, that's what I'm going for. I tried changing the Anti-aliasing samples to 16, but I doesn't help any :/ $\endgroup$ – RPiAwesomeness Dec 22 '15 at 23:15
  • $\begingroup$ Ah I misunderstood the problem. There's completely different approach then of course. You can use alpha channel of the text and blur it in the render (one way). However you should include information about render engine used $\endgroup$ – Mr Zak Dec 22 '15 at 23:38
  • $\begingroup$ @MrZak I've updated my question with what I thought was best. Let me know if that helps and/or if you need/meant more. $\endgroup$ – RPiAwesomeness Dec 23 '15 at 2:32
  • $\begingroup$ Please post the blend file for an accurate answer. I would question why you are using the Object TextCoords to drive ColorContrast to drive the MixFac between an Emission and Transparent shader. Is that necessary for pure white text? $\endgroup$ – Todd McIntosh Apr 21 '16 at 13:44
2
$\begingroup$

It looks to me like you are suffering from a lack of anti-aliasing.

If you are using cycles, you'll need more than one sample (Properties > Render > Sampling) in order to get good anti-aliasing. Try maybe 15 or so, and increase until the result is smooth enough for your liking.
Keep an eye on the rendertime though.

enter image description here

If your animation consists entirely of flat colors, I would recommend using BI or OpenGL render instead.

OpenGL

The OpenGL render operates using the same techniques for the viewport and realtime games. In other words, it renders nearly instantaneously (especially for flat colors).

To enable anti-aliasing when using OpenGL render, enable Anti-Aliasing in Info > Render > OpenGL options and choose a suitable number of AA samples (more == slower but smoother):

enter image description here

Blender Internal

If you need a little more than just flat colors (motion blur, for instance), then you might consider BI. While perhaps slower than OpenGL (depending on your hardware), it's still much faster than Cycles when it comes to flat shading:

enter image description here

$\endgroup$
1
  • $\begingroup$ I actually ended up taking a break from Blender/video work in general for a bit and have just now come back to it and while initially everything was rendering out greyscale, I switched the viewport to Material mode and then using OpenGL worked perfectly! Thank you! $\endgroup$ – RPiAwesomeness Jun 3 '16 at 22:43
0
$\begingroup$

You'd probably have to manually smooth the edges by converting the Text Objects into a Mesh or Curve Object. This is easily done by selecting your Text Object, and hitting [Alt + C].

$\endgroup$
1
  • $\begingroup$ I tried this and it helped a very small amount, but the edges are still very rough. :( $\endgroup$ – RPiAwesomeness Dec 23 '15 at 16:24
0
$\begingroup$

Try increasing the interpolation for the text.

After that you can convert the text to a curve or mesh by pressing Alt + C

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.