5
$\begingroup$

In my blender file, I have a simple castle in which when I try baking the Ambient Occlusion it generated a black texture. How can I get Blender to bake correctly instead of this black texture? Picture of UV texture in blender

I been reading on forums about this problem which mentioned about inverted normals but my normals or overlapping UV but I generated another without overlapping UV's and received the same problem. They also being negatively scaled but this model has positive scales ;(

Thanks in advance!

Blender file attached here:

$\endgroup$
3
  • $\begingroup$ I should be something related to the file itself: importing all the objects in a new file allows a correct baking. Is it the same for you too? $\endgroup$ – Carlo Dec 22 '15 at 2:45
  • $\begingroup$ Sorry for the late reply but yes I resorted to doing that afterwards. There's no problem when I export the mesh and reimport it into a new file but I wanted to know why it happened so I could prevent this from happening again :P $\endgroup$ – user11422 Dec 24 '15 at 23:09
  • $\begingroup$ try doing ctrl + n in edit mode and then try again. $\endgroup$ – user22324 Mar 2 '16 at 20:48
3
$\begingroup$

Try to set Environment Lighting to 1.0 in the World tab. I have tested it now and it bakes AO correctly then. The funny thing is that you dont need to check the Environment Lighting checkbox and it still makes the change.

$\endgroup$
2
$\begingroup$

I had one part of a mesh acting this way and fixed it by recalculating the normals.

$\endgroup$
1
$\begingroup$

I found that my selection of the baking options was the problem.

Initially I unticked everything except "Ambient Occlusion" (following a few online videos) - this left the primary baking type to "Combined", with direct and indirect light and Ambient Occlusion ticked.

Black bake.

I bounced around online for a while before going in to look at the settings again - the direct/indirect light checkboxes bugged me because I was pretty sure there were no such things in my scene, (just my model) so I decided to click on 'combined' to see what other options there were - and then I found an Ambient Occlusion bake TYPE.

When I changed the baking type to "Ambient Occlusion", direct/indirect light (and the other options) disappeared - then it worked.

I'm guessing the direct/indirect light options in combined when I didn't actually have any lights in my scene were why it was baking black - I'm assuming the bake-type "Ambient Occlusion" option ignores lighting, or provides it's own generic ambient light for processing....either way, that's what worked for me...

JS

$\endgroup$
0
$\begingroup$

Had the same issue, also discovered that the Physical Starlight and Atmosphere addon have to be turned off for the render passes to work propperly, in case that people having the same issue and add on c

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy