0
$\begingroup$

I'm using Blender hair particles for simulating grass and there are two issues.

1) Hair simulation is too slow, even when I set the number to 5 just to check how the grass blades move around. (No there are no Force Fields currently).

2) "Cache" is missing when "Hair" mode is used. This is Blender 2.76b

enter image description here

This means I can neither clear the cache nor bake the animation so I can preview it in the 3d view before so I know everything is fine before running the day-long rendering of the scene.

$\endgroup$
0
$\begingroup$

You should enable Hair Dynamics in order Particle System set to Hair mode to have cache, because

When set to hair mode, particle system creates only static particles, which may be used for hair, fur...

wiki page.

This type of Particle System may be animated using the cloth solver.

Baking particle system may be neccessary if something happens in the scene, i.e. animation is involved. If dynamic hair is disabled, it seems like hair won't change, so nothing to bake.

After you enable Hair Dynamics, Particle System will be accessible for baking results and previewing animation when it's played (and so on):

enter image description here

$\endgroup$
  • $\begingroup$ The info in the wiki isn't correct, the Hair particles are being animated the other way too. $\endgroup$ – Leo Ervin Dec 22 '15 at 5:23
  • $\begingroup$ @LeoErvin It can be animated if using Force Fields which have location data animated; afaik no other really useful way There won't be possibility to play animation and see some changes if only hair particles and fixed force field are used. $\endgroup$ – Mr Zak Dec 22 '15 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.