6
$\begingroup$

I remember Blender use to produce thumbnails in file explorer. I'm not sure what happened, but I've recently reformatted windows and installed 2.76b, and it still doesn't show them. I assume this isn't something on my end, and I found this thread which makes it seem as if there is something wrong with the installer:

https://developer.blender.org/T45389

My question is: is there anyway to manually fix it?

$\endgroup$
  • $\begingroup$ Do the files open from file explorer if you click them twice (or from context menu > Open With) ? Or the only problem is that you can't see the image of the file type in file explorer GUI ? $\endgroup$ – Mr Zak Dec 19 '15 at 19:21
  • $\begingroup$ The *.blend files open no problem, they just don't show a thumbnail of the scene. Instead it's the blender logo. $\endgroup$ – KoolMode Dec 19 '15 at 20:33
  • 1
    $\begingroup$ maybe related ? blender.stackexchange.com/questions/23269/… $\endgroup$ – cegaton Dec 19 '15 at 21:50
9
$\begingroup$

The answer courtesy of fmb501 at blenderartists (thread here) :

This appears to be a bug in the Blender installer, but the fix is fairly simple.

Open the Windows icon in the bottom left corner of your computer display and search for "command prompt"

Right click on the result and select "run as administrator."

There will be a small window with a black background and a blinking cursor.

Type "chdir c:\program files\blender foundation\blender" and press Enter (chdir is the command for changing directories with the command prompt)

You should now be at that directory.

Type "blender -R" and press enter. You should receive a message indicating that the registration has been successful.

Close any Windows Explorer windows and then open Windows Explorer again.

Navigate to a directory that has your blend files and you should now see thumbnails for all of your blend files. If there some blend files that don't have thumbnails, it's probably an old file before the thumbnails were added. Just open and save it again and you should see the thumbnail.

I'm not sure why Blender Foundation hasn't fixed this instalation problem by now. I'm wondering if you have to install blender as an administrator to get it to regiser the thumbnail dll.

Anyway, until it gets fixed, you will likely have to register as described above with every new installation.

$\endgroup$
2
$\begingroup$

If all else failed. Try this.

Download an older version of blender installer. I used version 2.66a from their previous versions archive. Since it's only 300MB I keep the 2.66a version on my harddisk. After installation of the older version your thumbnails should start working again.

Cheers.

$\endgroup$
1
$\begingroup$

"Show Thumbnails" is an option in Blender's User Preferences.

Just go to the User Preferences, click the top "File" tab, and then from there just click "Show Thumbnails" on.

$\endgroup$
  • $\begingroup$ I've had that checked, it either doesn't work or is for Blender's UI only. $\endgroup$ – KoolMode Dec 19 '15 at 21:19
0
$\begingroup$

It seems that there's an error in 2.79b version (on Win 10 1809) on registering shell extension. I ran "blender -R" command and it was successful, but no thumbnails appeared on .blend files. I searched the registry and found that the corresponding key written in .blend —> ShellEx —> {e357fccd-a995-4576-b01f-234630154e96} subkey (on my system it is {D45F043D-F17F-4e8a-8435-70971D9FA46D}) is only present in HKEY_CURRENT_USER\Software\Classes\CLSID. So I copied that key to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID also. And the thumbnails appeared (no need to restart Windows Explorer or rebuild the icon cache, just F5).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.