I made three models which will be tiled next to each other in a game.

Center Tile, Corner Tile, Edge Tile. Tiles

My problem is I have trouble positioning them next to each other, I've come to the conclusion the problem is the pivot point.

My most left tile, the pivot is directly in the center. But on the other two they are not in the center even though I used "Origin to center of mass" and also Shift-C and "Origin to 3D cursor".

I have also tried selecting the top vertices "the green part" and Shift-S "Cursor to selected", its nearly perfect but not quite.

Tile problem

How can I perfectly center the pivot point in the green part in each model?


1 Answer 1


The reason "Origin to Center of Mass" (or "Origin to Geometry") does not work is because your center of mass in not in the same location. The two tiles with dirt, have most of the geometry much lower.

To set the origin in the seam place as the your all green first tile requires a 2 step process.

  1. In edit mode, select the top 8 vertices of your tile. (Note that the pivot point can not be set to "3D Cursor" or "Active Element") Now press ShiftS > Cursor to Selected. That will move the 3D cursor to the location you want as the origin.
    enter image description here

  2. In object mode press CtlrAltShiftC > Origin to 3D Cursor.

animated gif

  • $\begingroup$ Hello David, I followed every step of your guy, the animation was very helpfull aswell. But when I do as you suggest my pivot is slightly under which where should be the center. I've uploaded an image to show my result imgur.com/ZNrcxKR $\endgroup$
    – Kim
    Commented Dec 19, 2015 at 17:21
  • $\begingroup$ @Kim are all your tiles' top sections the same height? If they are different thickness it will position the origin at different places. Also try setting the pivot point to Bounding Box. $\endgroup$
    – David
    Commented Dec 19, 2015 at 17:23
  • $\begingroup$ Yes I just checked by selecting the green part, press N and show "Mesh Display -> Length" and it says 2 in each direction in each model $\endgroup$
    – Kim
    Commented Dec 19, 2015 at 17:28
  • $\begingroup$ @Kim I meant height along the Z axis. but it is also that the meshes are the same size. $\endgroup$
    – David
    Commented Dec 19, 2015 at 17:31
  • $\begingroup$ Is there a smart way I can check that? Each of my models is in their own blend file. $\endgroup$
    – Kim
    Commented Dec 19, 2015 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .