7
$\begingroup$

I have a small army of zombies, with a sun lamp behind them. I set the sun from "No shadow" to "Ray shadow" and now the zombies have shadows. But the shadows are much too sharp. I changed the world settings to give indirect lighting, and gave it 3 bounces, but it didn't seem to affect it. Is there a way to make the shadows from the sun more blurred, less sharp?

$\endgroup$
  • 1
    $\begingroup$ Try adding another lamp, perhaps a hemi or area lamp - to simulate bounced lighting. $\endgroup$ – X-27 Dec 18 '15 at 16:11
9
$\begingroup$

Use the Lamp > Shadow > Soft Size setting. By default for a sun lamp, it is set to 0.1, which produces sharp shadows. Increasing that number will make the shadows cast by that lamp softer.

enter image description here

Note: in order for you to see the softer shadows in your render, you need to increase the Lamp > Shadow > Samples value to something higher than 1.

Example: Soft Size = 0.1

enter image description here

Example: Soft Size = 5.0

enter image description here

$\endgroup$
  • $\begingroup$ I thought i tried that, and it did nothing, but I looked at it again and it wasn't touched, sooo... Ah ha! It still did nothing, so I reread your answer, and I saw I had to mess with some other settings too (like sampling :P) $\endgroup$ – BookWyrm17 Dec 18 '15 at 15:09
  • $\begingroup$ This approach simulates a penumbra, with each sample helping define an intermediate gradient within the penumbra. $\endgroup$ – Dejay Clayton Dec 18 '15 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.