1
$\begingroup$

I have a simple box with a texture on it, using a UV map. The texture displays perfectly in Texture viewport mode, like so:

texture viewport

However, when I switch to Rendered mode, it's just a grey box. If I try to use Texture Paint, it says I have missing textures. (Material mode is a grey box, too, but that doesn't trouble me) I don't understand this. I seem to have a texture, or else Texture mode wouldn't display a texture. But Blender seems to think I don't.

How can I force Blender to use this texture in Rendered mode?

My material settings: material settings

My texture settings: texture settings

$\endgroup$
  • $\begingroup$ Add a sphere somewhere for ease of recognition. Please show failed render. Do you have lights? Have you pressed 0 (zero) repeatedly on your numeric keypad .... to ensure your Camera View is the same as your User View .... (If you make a mistake and press regular 0 zero you will need to press 1 (one) to see items .......... sorry for the potential lack of clarity) . Did you UV unwrap your 3D mesh? $\endgroup$ – atomicbezierslinger Dec 14 '15 at 23:12
2
$\begingroup$

Make Sure your 3D Mesh is UV unwrapped.

Your material must have a texture attached.

As a temporary investigation tool you may select ... Material Shading [Shadeless] or add more lights to the scene.

Here is an example.

enter image description here

We are in the texture pane ... indicated with red and white checkerboard icon. In the image above you see Object Name, Material Name, Texture Name ... next to the push pin. Reading that line verifies the attributes are linked. These names indicate an active hierarchy. Object with subordinate Material with subordinate texture. They are linked, attached, bound.

It can be confusing that in 3D View Window you may see an image temporarily on your mesh. Feature perhaps. During render only the texture pane setting will be rendered in Blender Render mode.

Because I created the object, then created one material while the object was selected, the material is bound to the object. Next I switched to the texture pane. I created a new texture immediately after viewing the material. The check box for the texture is selected. The texture is bound to the material.

I am simply restating the settings you see here for emphasis. Type [Image or Movie]. Image source you see a filename from the hard disk. By clicking the button you will see a select file dialog.

More texture settings.

enter image description here

Mapping UV with understood default name. Influence [Color]

$\endgroup$
  • $\begingroup$ How can I "bind" a texture to a material, or a material to an object? There are materials in the material list, but I can't tell if they are truly attached to the object or not. $\endgroup$ – Somatic Dec 14 '15 at 22:05
  • $\begingroup$ Select the object. Only add one material to your object at this moment. Then only add one texture. Start fresh. If you have any failed material ... DELETE them to remove any accumulated mistakes. Show your material and texture setting in your original question if you are allowed to do so. $\endgroup$ – atomicbezierslinger Dec 14 '15 at 22:30
  • $\begingroup$ Edited question. Thanks for your help so far. $\endgroup$ – Somatic Dec 14 '15 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.