1
$\begingroup$

I added the io_three folder from three.js to Blender's add-ons.

When I go to Blender user preferences, the three.js addon appears, but it prevents me from activating it. The warning says "importer not included."

enter image description here

Details in Warning Panel

^ Report inside warning panel.

$\endgroup$
3
  • $\begingroup$ are you familiar with manually installing add-ons ? like dragging/duplicating the io_three folder from the downloaded mr doob three.js directory into .../scripts/addons_contrib/io_three ? $\endgroup$
    – zeffii
    Dec 10, 2015 at 19:14
  • 1
    $\begingroup$ I would install it this way: blender.stackexchange.com/revisions/42841/3 $\endgroup$
    – zeffii
    Dec 10, 2015 at 19:31
  • $\begingroup$ @zeffii I just wanted to point out that after copying three.js/utils/exporters/blender/addons/io_three/ to ~/.config/blender/2.78/scripts/addons, I could not actually check the box. The only thing that worked was restarting blender a couple times. $\endgroup$
    – dylnmc
    Oct 19, 2016 at 0:49

2 Answers 2

2
$\begingroup$

The warning on the UI

enter image description here

is only telling you this is an Exporter add-on only. "Importer not included". Everyone using that version of the add-on will see that warning. It's not an error, if you look at the files in the three.js repository (blender/addons/io_three) you'll see that there's only an Exporter.

As for the report in the Warning panel, that's different.

$\endgroup$
3
  • $\begingroup$ while it may be only a warning, if the box still can't be checked, try restarting blender and going back to the plugins page a couple times. If you can't get it to work after restarting blender, then you do actually have a problem. cheers $\endgroup$
    – dylnmc
    Oct 19, 2016 at 0:50
  • $\begingroup$ the checkbox and that Warning "Importer not included" are two entirely different things. $\endgroup$
    – zeffii
    Oct 19, 2016 at 11:03
  • $\begingroup$ right. I couldn't mark the checkbox until I restarted blender. $\endgroup$
    – dylnmc
    Oct 19, 2016 at 18:06
1
$\begingroup$

Same problem was happening to me. When I click on the activate button, it just wouldn't activate. I just closed Blender and restarted it and then it worked.

$\endgroup$
1
  • $\begingroup$ The same thing happened to me. I kept clicking the box and waiting for a few seconds in case there was lag. It simply didn't work. I restarted blender, and - even though I saw the same warning about the importer as you did - the checkbox actually worked after the restart and allowed the add-on to be added within blender. $\endgroup$
    – dylnmc
    Oct 19, 2016 at 0:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .