2
$\begingroup$

I've been trying to install the Three.js exporter in Blender 2.76b on Ubuntu 14.04 and it's not showing up in the Addon's list in Blender.

I put the io_three folder in /usr/libs/Blender/scripts/Addons folder using Nautilus in gksudo mode and it's still not showing up when I open blender, any suggestions?

I even tried installing an older version of the addon as well and still no go. Do I need to install an older version of Blender to get it to work? I got it to work in Windows no problem.

$\endgroup$
  • 1
    $\begingroup$ If you start blender from the terminal is there any relevant output? $\endgroup$ – gandalf3 Dec 8 '15 at 2:25
1
$\begingroup$

I checked my console output, apparently I had 2 versions of blender installed and I installed it to the wrong folder:

It outputs connect failed: No such file or directory Read new prefs: /home/USER/.config/blender/2.76/config/userpref.blend

I didn't even know I had a .config folder, I put it in the ../config/scripts/addons folder and now it works great!

$\endgroup$
1
$\begingroup$

By default there are 3 places blender searches for scripts and data files, as well as some variables you can use to adjust it. The user location of $HOME/.config/blender/2.76/scripts/addons would be the more preferred location.

From the threejs Readme it appears that ubuntu is normally configured to search /usr/lib/blender/scripts/addons this needs to be exact and is case sensitive.

$\endgroup$
0
$\begingroup$

To put

io_three folder in /usr/libs/Blender/scripts/Addons

is wrong.

Blender has a scripts-folder containing the folders addons and modules.

Copy the whole \three.js-master\utils\exporters\blender into scripts of blender!

$\endgroup$
0
$\begingroup$

I got a problem with addon that was not showing in the list. In my case it turned out that "Hair Lab" was showing in the list as "grass lab". So if You have the same problem (no errors, when installing addon, but it didn't shown in user preferences) try to find in script name = ...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.