I am new to using blender and have been watching youtube videos on how to use it. I copied the steps of how to create cracks in a surface. I can see what it looks like if it gets rendered but then when I go to render it I get the message "no render output node in scene". It's not an animation, it's just a single image. Here is a screenshot of all my nodes and the error after trying to get it to render. enter image description here

  • 3
    $\begingroup$ Pretty sure this is because you removed the composite output in the compositing node tree accidentally. I'll write up an answer with more detail. $\endgroup$ Dec 6 '15 at 1:30
  • $\begingroup$ You just beat me to it. i am sure that is what it is. $\endgroup$
    – VRM
    Dec 6 '15 at 1:31
  • $\begingroup$ @shaunify Glad to help. I hate to ask this, but if my answer solved your issue, could you please accept it? Thanks :) $\endgroup$ Dec 7 '15 at 21:24

The issue is most likely that you removed the composite node accidentally in the composite node tree.

enter image description here

Select the composite node tree button (highlighted left).

At this point, we should take a step back, and make sure that what I think is happening, is happening.

There are two signs that I'm wrong:

  1. Use Nodes isn't enabled
  2. There is a composite node

If both of those aren't true, then continue.

Now there are two ways you could solve this.


You could disable Use Nodes. When this is disabled, anything in the compositing node tree is ignored.


Or you could add in a composite node, and attach it to the Render Layers node.

ShiftA output -> composite.

enter image description here

And then attaching the render layers node to it.

enter image description here

  • $\begingroup$ To add to TARDIS Maker, sometimes the problem is that you don't have a Material Output node in your material. Add one: Shift+A >> Output >> Material Output $\endgroup$
    – sam1370
    Aug 19 '18 at 17:08
  • $\begingroup$ Also try unchecking "Sequencer" in Output Properties >> Post Processing. Worked for me. $\endgroup$
    – dvlcube
    Oct 26 '20 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.