3
$\begingroup$

I made a scene with a lot of instance objects (Alt+D) and when I press 'Apply' to the Displace modifier, it doesn't let me.

Is there any way to make it work? Or make the animation of the Displace modifier be still?

I was thinking on copying one, keep the parameter, then deleting the modifier on the instances and then link the instanced object modifier but...it still doesn't work. Or maybe an option to make the objects as separate in order to apply the modifier? I need to apply it because it's animated, and I need it still.

enter image description here

$\endgroup$
2
$\begingroup$

You can create a plain duplicate using ShiftD (instead of a Linked Duplicate).

Then apply the modifier on the duplicate. Now this unique mesh data will have the modifier applied to it.

After that, for any object that you want to use the modified mesh, just go to the Mesh Context and select it from the drop-down list.

Mesh Context drop-down list

In this example 'Cube.001' is the mesh with the modifier applied.

$\endgroup$
  • $\begingroup$ What i did for now as a temporal solution was to unlink the elements using the Plugin 3D view: Copy Attributes Menu and it works, still the problem here is that i can't apply the modifier to an already made object, because it's even already animated and i didn't choose to add this modifier before i was almost finished with the scene. $\endgroup$ – beavoru Dec 4 '15 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.