I have a a GeForce GTX 980 Ti and a GeForce GTX 760 installed in my system. I just tried rendering a scene that I know will render fine with the GTX 980 Ti but when I render with both cards I get "CUDA error: Out of memory in cuArrayCreate(&handle, &desc)". I know exactly what is going on. Blender lists the Compute Devices as GeForce GTX 760 + 980 Ti. Even though the 980 Ti is in PCI bus 1 and the 760 is in PCI bus 2, it is obvious that Blender is using the RAM from the weakest card. Since this seems like a real handicap, I was wondering how I can force Blender to do the right thing, the common sense thing, and use the memory from primary card with the largest amount of RAM when rendering my scene with both cards.


Blender is actually using the memory of BOTH cards. The scene has to be fully loaded into both GPUs as they are entirely separate. They cannot share memory. You are limited by the size of the smaller card. The order in the preferences makes no difference.

There is no way to fix this, and no way to have it not use selected cards with insufficient RAM to hold the scene. The only option is to set it to select only the larger card for the time being.

| improve this answer | |
  • $\begingroup$ Well, that is too bad. Hopefully a better solution gets implemented. I will only render with both cards when it fits in the memory of the smallest, since that is the way it is. $\endgroup$ – Bryson Jack Dec 4 '15 at 14:51
  • $\begingroup$ Assuming it takes memory to run displays from a card, would it be better to leave my larger card to drive my monitors so the smaller card has the max amount of RAM when rendering from both cards or is there no RAM involved in driving monitors? $\endgroup$ – Bryson Jack Dec 4 '15 at 15:26
  • 1
    $\begingroup$ Yes, your monitors will take a couple hundred MB of ram each, depending on what is happening on them. So you could put them on the larger, or you could run them all off the smaller if you are only able to render on the larger and want the max size. $\endgroup$ – Ascalon Dec 4 '15 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.