I have imported a build-set roblox roblox studio into blender. It looks like this: without texture

But when I click the textured solid, it looks like this and all of the colours in the background have dissappeared: with textured solid

Is there any possible way that the colours in the background (the door & bed) still keep their colour, but also te textures are shown with it?


2 Answers 2


The colors will appear once you render the picture. I had this same problem.

Go under System Preferences > Input , and look for Emulate Keyboard (turn this on temporarily). Now exit out of that and press 0 on the keyboard. The exterior should go grey and show a frame. use Shift + F to navigate and find your desired camera angle then click Render on the side of the screen in the render settings menu.


You should switch to GLSL and try Material mode instead of Textures. Basicly your background objects do not have any textures. What your see in Solid mode is the color of the shader.

I'm not really used to blender render but in Cycles:

Texture Mode: Will display the latest selected texture node / Slot.

Material Mode: Tries to display maps mixes properly (allowing texture layering right in Blender's viewport)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .