I want to run out and buy a pair of active shutter 3D glasses so I can watch and adjust animations in the 3D viewport using time sequential mode, but the part about the graphics card supporting Quad Buffers stopped me. I have read here that my MacBook Air might support this function, although it's not really clear to me if this applies to shutter glasses and the laptop display itself.

While the Anaglyph option is a quick way to get started, I need to use full color.

Any info or experience using Blender Multiview on MacBook with active shutter glasses would be greatly appreciated.


2 Answers 2


Full disclosure: I don't have a Mac and I've never set up an active shutter 3D display of any sort. I will NOT be able to tell you anything for absolutely certain. But with no one else responding to you at this time I'll tell you what I do know!

Unfortunately, I think your suspicion about whether the laptop's display is compatible is the real problem. The related post you referenced seems to be mostly talking about getting 3D to work with unspecified monitors, so I get the impression they are using other monitors (not the laptop's display). According to this related post which references this article your monitor needs a refresh rate of at least 120Hz. I was not able to find anything conclusive about a MacBook Air's screen's refresh rate (I'd need to know which model/year of the MacBook Air you have for one thing) but I would be surprised if it did support anything over 60Hz. Laptop screen's are not likely to support high refresh rates in my experience (again, I don't know, and you should look up your model and make sure).

But even if it does support 120Hz, it's just not that simple. Typically for monitors to support 3D properly they need to be designed "3D ready" for it to be likely to work reliably. Even if your monitor seems like it has all the specs for it, so much has to go exactly right for the active shutter glasses to sync up with the monitor and produce a consistent 3D effect that unless the monitor was designed for it, it just probably will not work. (Again, you should look up your model and see if it mentions a "3D ready" monitor or "stereo compatible" or anything else indicative like that anywhere.)

Add on top of that any complications with actually setting up Blender to cooperate with the active shutter 3D on Mac OS, and I think your chances of getting it to work are not good. Also, you would definitely have to find a pair of active shutter 3D glasses with Mac OS compatible software, which could be tricky.

But as I've been stressing throughout this whole post: I don't know. I'm not an expert and I don't know enough about your machine. It just seems unlikely.

Sorry for all the disparaging news, and sorry for not being very authoritative! Good luck.

  • $\begingroup$ Wow, thank you for taking the time to reply! OK I'll have to hold out a little longer before becoming "3D" enabled. I'm hoping to read a tutorial soon "Here's now to see 3D in Blender's 3D window". $\endgroup$
    – uhoh
    Commented Mar 19, 2016 at 6:44
  • $\begingroup$ @uhoh Ha! Agreed. Thanks for catching those. $\endgroup$ Commented Mar 19, 2016 at 12:58

I had these problems with my internal Intel HD 4000. I wanted to use my laptops second GPU, an AMD Radeon HD 8790M. But unfortunately for this Dual GPU laptops you are dependant on your manufacturers driver support - so in the end it didn't work out for me.

I filed two Bug reports:

  • The first helped me to find out that the problem on my side is with the driver. The devs told me to use the opengl32.dll from http://download.blender.org/ftp/sergey/softwaregl/ and place it next to my blender.exe. That's only applicable for Windows though, but it showed me that the problem wasn't in Blender (as with this software render mode it worked really slow but fine).
  • The second one concluded in Dalai updating the manual mentioning the Triple Buffer:

    Multi-View drawing requires capable graphics card and drivers with Triple Buffer support. If the Automatic mode doesn’t work, set the Window Draw Method in the System User Preferences.

So for your case, I'd suggest, you'd try to figure out in general whether your 3D view is working under Windows with this OpenGL-Wrapper. And finally you have to make sure, your MacBooks graphics card supports Trible Buffer.
I was able to use the 3D Stereo View with my line interlaced Zalman Trimon ZM-M240W 3D Monitor in software mode (like a slideshow). But this has nothing directly to do with 120Hz or not - that's just needed for using Shutter Glasses. With a line interlaced Monitor you don't need this, it just halves your horizontal resolution (but you won't really notice this and the 3D effect outweighs this limitation!).

So in general it is working, but not unfortunately not with my manufactures dual GPU drivers. And I can imagine a similar problem exists for your MacBook that one of the key factors (TripleBuffer support) is missing.
The first step is to get 3D working with a MacBook in general (which I didn't hear of being possible yet) and after that you might try to setup Blender to show your Viewport or renderings in stereoscopic 3D.

  • $\begingroup$ I get lost at "...working under Windows,,," what do you mean? $\endgroup$
    – uhoh
    Commented Mar 20, 2016 at 5:28
  • $\begingroup$ Oh, I thought you might try to use a Windows virtual machine or a dual boot if possible and check if your hardware will show the stereoscopic view (you could try line interlaced for this check) with this wrapper dll. Unfortunately it is not for iOS. But when it doesn't give you an error, but behaves as you want, you know that your problem (if this behavior is with the software emulation only) is one of your graphics driver. On my system the line interlaced 3D View shows fine with it but won't work without using it. $\endgroup$
    – Samoth
    Commented Mar 20, 2016 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .