1
$\begingroup$

When I set Blender to metric units with scale '0.01' (centimetres) or any other scale, except '1', I meet a bug.

Sometimes, Blender displays some values in meters. If I click into value and then press Enter immediately, it changes units to centimeters, although such operation should not change anything.

Proof: https://youtu.be/cJ-TfmF0PlI

UPDATE

It is a bug and it can be fixed.

One way is to adjust value after click. Initially it was 1.54844 m. Once clicked, it became 1.54844. Since absent units means cm, Blender should change the value to 154.844 immediately after click.

Other way is to retain unit in the window, but make it not selected, like windows do on file rename. Once I click F2 on file with extension, it selects name but extension:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ This isn't the place for filing bug reports. See blender.stackexchange.com/questions/1377/… $\endgroup$ – gandalf3 Dec 4 '15 at 19:43
  • $\begingroup$ Not everybody agree it is bug. So as me could not know it is bug until asked. Regard this as a question: is this a bug or feature? $\endgroup$ – Dims Dec 4 '15 at 19:46
4
$\begingroup$

By default Blender interprets input at the base unit measurement in that system. All you need to do is to input a unit as well as a quantity and this will work as expected (i.e. 12m or 12cm etc.)

As you have noted in your question, changing the Scale option changes what this base unit is. In your case the base unit is cm, so for any other unit of measure, you must input that unit after the numerical input.

$\endgroup$
  • $\begingroup$ Yes I understand this, but anyway it is a bug, since I didn't do anything while Blender changed the value. $\endgroup$ – Dims Nov 28 '15 at 19:17
  • $\begingroup$ No, it is completely expected. There has to be a default unit. All that is happening is that it is not carrying the units over when you edit them. You need to add them again. I agree that the feature you mentioned in your question should be added. $\endgroup$ – VRM Nov 28 '15 at 19:41
  • $\begingroup$ I don't edit anything. I just click and confirm. No editing. This is blender who change the value, not me. It treats it inconsistently. $\endgroup$ – Dims Nov 28 '15 at 20:11
  • $\begingroup$ You did not read my comment very carefully . . . $\endgroup$ – VRM Nov 28 '15 at 20:12
  • $\begingroup$ I have read that you suggested to enter the unit explicitly which is not contradicting the point that it is a bug. $\endgroup$ – Dims Dec 4 '15 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.