1
$\begingroup$

I am using blender 2.76b. I am trying to export my model to dae file. My model has an Icosphere and Sphere with image textures applied to both. I have checked the Copy and Include Material Textures while exporting.

When I render the scene the object look fine with image textures applied to it. As Copy is checked, Blender automatically exports the image textures in the same directory as dae file.

When I try to import this dae file in Shiva3d or Sketchup, I can see the objects but I am not able to see the object with image textures applied to it.

I am facing the same problem when exporting to 3ds file

I can't figure out what the problem is. Can any help me figure out the problem

=======================================================================

I am successfully able to export the textures UV Map to dae file. Please have a look at the output below. The problem is that the textures are getting applied to individual faces rather than whole object.

Textures applied to Pool Balls

I want the textures to be applied to the whole object and not individual faces. How do I fix this problem.

$\endgroup$
3
$\begingroup$
  1. Don't export from cycles but from the Blender internal.
  2. Make sure the model is unwrapped.
  3. Make sure the mapping coordinates is set to UV Map.
  4. Make sure the UV map is assigned.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

This video shows the steps for applying the texture to a sphere (with "cillinder projection"):

https://www.youtube.com/watch?v=DaA_YJx7Auw&feature=youtu.be

$\endgroup$
  • $\begingroup$ Hey Abel. Thanks for your detailed reply. I am successfully able to export to dae file but the textures are getting applied to individual faces not whole object. I have edited my original question to add my sketchup output. Can you please have a look $\endgroup$ – Jayesh Duggal Nov 29 '15 at 5:14
  • $\begingroup$ When I use Generated coordinates, the textures get applied to the whole object but I cant export into dae correctly $\endgroup$ – Jayesh Duggal Nov 29 '15 at 5:29
  • $\begingroup$ It's all about how you unwrap your object and how you assign the texture to the unwrapped object... Is your goal to add the texture to a sphere? There are different way's to wrap a texture to a sphere correctly... For a Sphere I would suggest using cylinder projection. But be aware of stretching texture area's on the poles... Can you upload your blend file and texture with this app: blend-exchange.giantcowfilms.com so I can take a look... $\endgroup$ – Abel Nov 29 '15 at 11:24
  • $\begingroup$ For more info about "how to unwrap a sphere correctly" look at these links: blender.stackexchange.com/questions/10741/… , youtube.com/watch?v=yc0b5GcYl3U , youtube.com/watch?v=9Ha2rFR6qO0 $\endgroup$ – Abel Nov 29 '15 at 11:24
  • $\begingroup$ I've added a video for using a sphere and "cillinder projection". youtube.com/watch?v=DaA_YJx7Auw&feature=youtu.be $\endgroup$ – Abel Nov 29 '15 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.