3
$\begingroup$

would love some help with this as Im probably missing something simple so here's the issue...

  1. I save a UV map (from UV master) on the low res in Zbrush and polly paint my high res and create a normal and diffuse map from it. I then hit GoZ and all goes across to blender perfectly
  2. In blender I can view my textures by pressing alt z and they look fine, and also when I render. I then put in a meta rig, rig it, weight paint, animations etc.
  3. Now when I export FBX to unity the model comes across fine with anims etc. But when I drag my textures (normal and diffuse) onto the FBX mesh (which should have exported with the UVs) its like the UVs are completely different or massively messed up, we are not talking a few stray seem artifacts, but rather a complete picasso, with large sections of black on the model where the bg of the diffuse is being used. Hence I am assuming my UV has issues (or blender has created a new default one in the export?. I thought that the Zbrush UVs had come across fine as the texture is displayed properly in blender, but perhapse they are not assigned as UVs in blender? I have no idea about UVs in blender.

This happens with multiple meshes (static objects and rigged characters).

Also just going from Zbrush (with an x normals bake) to unity with no blender involvement works fine on the mesh (it just isn't rigged :( ).

Thanks so much for any help.

$\endgroup$
  • 2
    $\begingroup$ are the UVs OK if you re-import the fbx to Blender? If so, the export works at least, the problem has then to be searched for on the Unity side. Otherwise you'll know there's something to look into on the Blender side. $\endgroup$ – aliasguru Sep 24 '16 at 13:59
  • $\begingroup$ Have you checked the texture size and settings in the inspector in Unity? Also have a look at the 3D model import settings for that model in Unity. As aliasguru mentioned, it's more likely to be a problem on the Unity side. $\endgroup$ – Simone Oct 24 '16 at 13:46
2
$\begingroup$

I'm having this exact issue, only iv'e used Maya. I created my high poly sculpt in zbrush, then rigged, animated, and UV mapped him in Maya. But the exported fbx has broken UVs in Unity... its maddening.

solution for you there are two UV layers in all imported assets in Unity. In the material inspector, try switching from UV0 to UV1 (in drop-down menu). Hopefully this fixes your problem... If not then you and i are truly in the same boat. Which tells me its likely a Unity problem, since we're using different modeling/animation software.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.