2
$\begingroup$

I want light but no shadows using emission lights. Even though I uncheck the Ray Visibility "Shadow" I'm still getting shadows. enter image description here

$\endgroup$
7
  • $\begingroup$ There's two lights in your scene, un-ticked on both? $\endgroup$ – Luka ash Nov 26 '15 at 21:59
  • $\begingroup$ Yes, both are unticked. I quadruple checked. $\endgroup$ – Marc Nov 26 '15 at 23:19
  • 2
    $\begingroup$ Have you tried unticking the shadows on the object? $\endgroup$ – user1853 Nov 26 '15 at 23:40
  • $\begingroup$ Yes.. shadows are UN-ticked on every object. Very bizarre. $\endgroup$ – Marc Nov 27 '15 at 2:05
  • $\begingroup$ No matter what I do I am STILL getting nasty hard-edged shadows. I attached the blend file above except I forgot to bake the graphic in.. still you can see what I mean. $\endgroup$ – Marc Nov 27 '15 at 17:05
4
$\begingroup$

First, the answer to the question:

To get rid of shadows in cycles, you can disable Shadow in the Ray Visibility of the object (not the emitter).

enter image description here

BUT

Those are not shadows you are looking at, they are reflections of the object itself.

You've created a very reflective, almost mirror like material.

enter image description here

Without changing the lights, here's a render using a diffuse shader on the object, the alleged shadows are gone....

enter image description here

Here's the same scene with a glossy only material, showing the reflections on the glossy sirfaces...

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.