I am rendering animation in Cycles Renderer and I noticed that for each image render, renderer loads all textures.

Is there a way to tell renderer to use same textures for every frame (whole animation) and not to load them every time new image is being rendered?

Considering I am using over 100MB of textures it would make rendering notably faster.

(PS. I am rendering on GPU)


Here is my simplified blend file https://www.dropbox.com/s/v5sbs56wd8pq3xh/textureLoading.blend?dl=0. It is on Dropbox because Blend-Exchange has 30MB limit. Dead link

Edit 2:

When rendering on CPU, loading is barely noticable but on GPU (I have GeForce GTX 760) it takes around one second and you can see rendering "pauses" between each frame.

  • $\begingroup$ I think your question will remain unclear without any insight to your texture settings... $\endgroup$
    – Abel
    Nov 26, 2015 at 20:56
  • $\begingroup$ I wish there would be a way to make cycles not reload the texture on every render/frame like the Blender internal does. Thought "Persistent Images" would do the trick, but no. All I can find are simular situations with workarounds like using low res images or bitmaps like here: blender.stackexchange.com/questions/27690/… $\endgroup$
    – Abel
    Nov 27, 2015 at 12:03
  • $\begingroup$ Thank you for "Persistent Images" it actually took one second off each frame rendering time. Plus it led me to this site blenderguru.com/articles/4-easy-ways-to-speed-up-cycles. Beside the article itself a lot of comments are helpful too. $\endgroup$ Nov 27, 2015 at 15:02

1 Answer 1


Activating "Persistent Images" in Render -> Performance helped. Plus activating some other options in Performace section sped up rendering too. This article http://www.blenderguru.com/articles/4-easy-ways-to-speed-up-cycles could be useful for some. Beside the article itself a lot of comments are helpful too.

  • $\begingroup$ Enabling persistent images eliminated a 15 second lag between each frame - a big deal when it only took 8 seconds to actually render a frame. My image was a 54MB navigation chart which remained static anyway. $\endgroup$
    – Joshua
    Dec 25, 2017 at 8:18
  • $\begingroup$ Enabling persistent images improved my render time from 40 to 4 seconds per frame. Was using a 900MB PNG as asteroid texture. $\endgroup$ Apr 13, 2020 at 4:19
  • $\begingroup$ Still a perfect solution in current Blender version 2.91.2, this checkbox cut my animation render time in half. (GPU rendering on GeForce 1070 GTX) $\endgroup$ Feb 7, 2021 at 7:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .