4
$\begingroup$

I am doing this Blenderguru tutorial to work on my modelling skills. At about 28:30 min in the tutorial it is demonstrated how to assign a material to a selected part of the mesh (another material is already assigned to the object). Now I have read this post and I think I have selected the right area (with face select) and assigned the new material but it does not work. Why ?

enter image description here

$\endgroup$
  • $\begingroup$ These answers were very very helpful !! $\endgroup$ – Old Man Nov 24 '15 at 20:26
5
$\begingroup$

You only have one material assigned to your object. To assign multiple materials to different parts of a mesh you must have multiple materials assigned to the object.

At the top of the Material properties tab there is a selection box which shows all materials currently available to the object. This does not mean that all these materials are used on the object, it means they are available to be assigned to parts of the object. By default, the entire mesh uses the first material in this list.

enter image description here

On your object, there was only one material ("Transparent") in this list. To add a material to this list, click the + button to the right of the material, you can then select a portion of the mesh and hit the Assign button to assign the selected material to that portion of the mesh.

Under the Settings rollout there are options to change the material's color in the viewport. It is often useful to change this for some material[s] when there are multiple materials on an object so you can see which ones are on which parts.

enter image description here

$\endgroup$
3
$\begingroup$

I think it is the window refreshing problem. As you can see below, after assigning a new material I entered Edit Mode, then Object Mode (Tab) and everything went back to normal. enter image description here

TIP: Remember, that in Cycles (as opposed to Blender Render), to see the assigned material colors in solid shading view you have to go to Material header-->Settings and change the Viewport Color there to corresponding material color (hover your mouse over the material color window, press Ctrl+C to copy it, then Ctrl+V to paste it to the window in Settings panel. enter image description here

$\endgroup$
  • $\begingroup$ In his .blend file there was only one material on his mesh. $\endgroup$ – PGmath Nov 24 '15 at 16:25
  • 1
    $\begingroup$ @Gonzou I took twenty seconds too long to answer! $\endgroup$ – cegaton Nov 24 '15 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.