I am pretty new to blender, but I've been digesting as many tutorials and reading as I can get my hands on. I've run into a problem and I can't quite form the question properly for Google to handle so I've come here for help.

When I manipulate the arm IK bone most of the mesh behaves normally. However, when I do manipulate say the left arm IK, there ends up some twisting and deformation on the right breast of the mesh. I've checked the weight painting and nothing on the left side is connected over there.

I'm not entirely certain what else it could be. I've checked the parenting. I checked the weights and made sure to subtract everything that needed it. I'm stumped. I have before and after pics and I will certainly make the .blend file available if anyone needs to look more closely.

Thank you.



*Here is the blend file.

  • 2
    $\begingroup$ I guess sharing the file could let anyone else check also what you already checked. blend-exchange.giantcowfilms.com is an option. $\endgroup$
    – m.ardito
    Commented Nov 24, 2015 at 11:00
  • 1
    $\begingroup$ @m.ardito I went ahead and did that. Hopefully this will get me some help. $\endgroup$
    – Adam Raetz
    Commented Nov 24, 2015 at 15:35
  • $\begingroup$ By inspecting your file I discovered your weight-painting is messy. All the artifacts are caused with some leftover rogue weights. They are hard to see because they are just shades of blue. $\endgroup$ Commented Nov 24, 2015 at 15:49

1 Answer 1


Yes, I checked the file, there are still subtle weight painting errors... I know they're subtle because it's difficult to see because they are just drawn in a slightly lighter blue colour, and some weighted vertex somewhat hidden into the folds of the suit of the character. but trust me, that is the problem. I can show you where they are some, in an image:

enter image description here

I removed all of them from the right IK arm, and now it moves just the supposed geometry.

There is a way to help you spot those subtle areas, and you can use it temporarily just to fix your weights: in the user preferences, activate the "custom weight paint range", and setup one that will help you, like did here:

enter image description here

Here I setup 2 control points in the colorramp:

  • the first is at 0 exactly (vertices with zero weight): black
  • the second, at 0.002, white (vertices with weight 0.002)

you cannot even see the black (zero) point, because it's very, very near to the white, but it's there.

in this way it's very easy to see where the bad paints are... when finished, just disable this feature, and get back to the default rainbow scheme...

  • $\begingroup$ Thanks so much I never noticed those real light paints. I will try out your advice and clean it up. Thanks again! $\endgroup$
    – Adam Raetz
    Commented Nov 24, 2015 at 18:59
  • $\begingroup$ Worked great. Cleaned up the sneaky spots and it works as intended for a simplementation rig. Thanks much! $\endgroup$
    – Adam Raetz
    Commented Nov 25, 2015 at 1:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .