2
$\begingroup$

I've tried and tried to figure out what setting I'm missing, and I'm starting to believe that maybe it just doesn't work. I'm using the internal Blender Render. I have a subtle blend transparency for my eyelashes on this model, and a "wet" transparent sphere around the eyeballs (separate from the eyes). When the lens of the glasses, with raytraced transparency for refraction, are in front of the eyelashes and eyespheres they don't render at all. If I change from raytraced to z-transparency, they render properly, but I don't have that nice refraction to make the lenses look more realistic. Any idea on how to solve this? I'll upload the .blend if requested.

Here's a render of each uploaded to imgur for reference.

Z-Transparency:

enter image description here

Raytraced:

enter image description here

$\endgroup$
7
  • $\begingroup$ Is "Receive Transparent" checked under the Shadow properties of the wet eyeball material? It might need to be checked so that a light can shine through the glass. $\endgroup$ Nov 23, 2015 at 19:47
  • $\begingroup$ Thanks Spencer. I believe it is enabled, but I'm away from my computer at the moment and can't check until I get off work tonight. I tried different combinations of enabling receive transparent with the lenses, eyelashes, and eyeballs and doesn't get the right result. Is there anything else that might be the issue? $\endgroup$ Nov 23, 2015 at 20:22
  • $\begingroup$ Not that I can think of... I do most of my renders with Cycles which would handle this case correctly. $\endgroup$ Nov 23, 2015 at 20:59
  • $\begingroup$ My computer isn't the best, so Cycles takes a ridiculously long time to render anything decent compared to Blender Render. $\endgroup$ Nov 23, 2015 at 22:32
  • $\begingroup$ Are you absolutely sure that, if not rendered across the lenses, those details are actually rendered in raytraced mode? any further investigation requires the file (or at least a sample which behaves in the same way)... $\endgroup$
    – m.ardito
    Nov 24, 2015 at 13:04

1 Answer 1

1
$\begingroup$

You should check the Traceable property on the Eye_transparent material. This allows the material to be evaluated during raytracing calculations and will therefore let the specular highlight on the Eye_transparent geometry be seen through the raytraced glass.

This isn't strictly related to your original question, but I'd also recommend enabling mirror raytracing on your lens material to increase their realism. I recommend setting reflectivity to 1, fresnel to 3.5 and blend to 1.15. Fresnel reflectivity is really important to capture accurately for a realistic render, particularly for glass and water materials. I also think that your skin material could benefit from lowering the subsurface scattering radius a little bit. This is just my two cents and of course for a glass material to look really good it has to have an environment to reflect.

$\endgroup$
1
  • $\begingroup$ Oh I absolutely appreciate it. The only thing I'm decent at is modeling so I'll take any tips on rendering, texturing, everything. Thank you, I'll try that when I get home. $\endgroup$ Nov 26, 2015 at 0:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .