1
$\begingroup$

I have applied a material and texture to a blender mesh. It renders in the 3D view with a white background in the texture paint mode. Is there a way to show the transparency correctly in this view?. Having read posts on the internet about rendering alpha, suggestions were you need to: 1) Ensure the texture is set up to influence the alpha channel (which it is) 2) "use Alpha" is ticked in the texture image options 3) Material is set to "Z transparency", with an alpha and specular value of 1

In the material window, you can see the transparency working. However in the 3D texture paint view, it shows as a white background.

Thanks, Mark.

$\endgroup$
1
$\begingroup$

Does it help if you switch the shading of the 3d view to GLSL? You can switch between "Multitexture" and "GLSL" in the properties panel (open with N key in the 3d view), under the "shading" group. Material alpha should be 0, and texture alpha influence > 0 (texture transparency shows transparent in the material) or <0 (the inverse of the texture transparency shows transparent in the material)

See this example:

enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Hi, I have tried those settings highlighted above - The only new one was the GLSL shader - it seems to do the same really. I also set the alpha in the Z transparency material setting to 0 as you have above. All other settings were the same. I did try changing the alpha influence to -1 from 1, and this also didn't change anything on the screen in the texture paint mode. Thanks. $\endgroup$ – Mark Nov 26 '15 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.