2
$\begingroup$

I have a problem with an image not showing up in the preview tab for the SkyTexture. In the screenshot below you can see the image is displayed correctly when used as a Background image in the 3d-view. I'm using the image as an environment texture. Any help welcome! (I'm using blender internal).

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

In your world settings, do you have real sky, and environment lighting enabled? Here are the steps to get your desired results. Go to the world tab and click real sky, then environment lighting. Then, make sure that you have sky texture selected in the drop down menu off to the right. Next, go to the textures tab and choose your image. Set the mapping as you already have, and click horizon, and that should do it. The world settings I use are as in the attached screenshot.World settings Hope that helps.

$\endgroup$
4
  • $\begingroup$ thanx for the reply. I can get it to work using texture type "image or movie" but not as "environment map". Seams odd to me, but maybe it just doesn't work that way? $\endgroup$ Commented Nov 19, 2015 at 19:54
  • $\begingroup$ I may be wrong, but I don't believe that it can be done as an environment map. The only way I've ever known of is as "image or movie". $\endgroup$
    – Timaroberts
    Commented Nov 19, 2015 at 21:30
  • $\begingroup$ Hmm, so what is the texture type "environment map" used for? $\endgroup$ Commented Nov 20, 2015 at 0:03
  • $\begingroup$ It basically takes a render of the scene and uses it as a texture to create reflections from my understanding. Here's a link to the current Blender documentation, it might help explain a little better as I don't use environment maps myself. blender.org/manual/render/blender_render/textures/mapping/… $\endgroup$
    – Timaroberts
    Commented Nov 20, 2015 at 1:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .