1
$\begingroup$

I'm trying to paint textures on different objects by UV mapping and painting - maybe I'm doing this wrong or in the wrong order, but whenever I select new shapes to work on and unwrap them, they open on the same image in the Image Editor, on top of each other - although I selected "New Image".

enter image description here

On the enclosed screenshot, you can see that the meshes are overlapping, which creates a confusing image.

I am trying to unwrap a new shape, which doesn't even shop up over the previous ones anymore...

To reproduce this problem:

  • create new file; in new file create monkey head and ico sphere in Object mode;

  • select monkey head in Object then in Edit mode, unwrap Monkey head and see it unwrapped in the UV/Image Editor

  • create new Image in UV editor, click OK

  • paint something on the unwrapped monkey head, save as image

  • select ico sphere in object then in edit mode, unwrap it: where does the unwrapped image appear? Even if you create a "new image" in the UV editor, the ico sphere doesn't seem to show up anywhere.

Another way to reproduce this:

  • create new file

  • go in Edit Mode, add Torus and Monkey Head

  • open UV Editor, create new image in UV Editor, in the Edit view, unwrap while all are selected

  • notice how all shapes overlap in the unwrapped view

  • create an ico sphere, unwrap it: where's the unwrapped version?

$\endgroup$
  • 1
    $\begingroup$ Does Pack Islands (Ctrl P) help? $\endgroup$ – gandalf3 Nov 18 '15 at 7:55
  • $\begingroup$ Can you elaborate a bit? In which window would this shortcut be effective, and what am I supposed to see happen when I press it? (in 3D view it asks "make vertex parent?" and on the image editor, CTRL+P does nothing) $\endgroup$ – MicroMachine Nov 18 '15 at 8:00
  • $\begingroup$ In the UV editor, but while in View mode. (Change Paint to View in the header, at the bottom of your screenshot). It should re-arrange separated parts of the UV map to cover as much area as possible without overlapping. You can tweak the margin and other settings in the Redo panel (F6) after running the operator. $\endgroup$ – gandalf3 Nov 18 '15 at 8:05
  • $\begingroup$ Right, when I go to "View" mode in the UV Editor, I see a clean black image. But the old meshes are still there (visible in "paint" view). If I create a new image, the meshes from old objects are always visible in paint mode. $\endgroup$ – MicroMachine Nov 18 '15 at 8:19
  • $\begingroup$ Are you in edit mode in the 3D view? $\endgroup$ – gandalf3 Nov 18 '15 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.