I'm not sure why my lamp isn't working. Here are the screenshots:

screenshot of solid view

screenshot of material view

  • 1
    Your lamps are working well. The problem is the plane (on which the joystick lies) has the Glossy node Roughness value set to 0, which means it reflects the World (which has a very dark color) in 100%. The joystick has a Glass material, which reflects a very dark World color as well. Try to set the World color to something brighter or set up the HDRI image for Environment Texture. – Paul Gonet Nov 16 '15 at 0:00
  • 1
  • Thanks @Gonzou I never knew that roughness on the texture played a role in light reflection. – lakerice Nov 16 '15 at 0:20
  • Thanks @gandalf3 that was a great explanation of this issue in the link you provided – lakerice Nov 16 '15 at 0:21
  • @PaulGonet OMG. I searched for 1 hour why my scene is dark with portals. It was because the world-color was set to a very dark color. In all this tutorials no one is talking about the world-color. Thank you very very much! – C4u Feb 14 at 13:53
up vote 4 down vote accepted

You have a couple of problems:

  1. You are trying a glass object and a glossy black object (the plane). Highly reflective objects need something to reflect! Create some environment and you'll see that your lights work.

  2. Your objects are quite large! So the lights also need to be a bit more more powerful

Here's your scene with a white hemisphere and your lights a bit brighter: enter image description here

To leave the environment out of the rendered image turn off the visibility for the camera

enter image description here

Blend file to play with:


EDIT:

if what you are after is some glow in the dark effect you might want to add a plane with an emitter shader as a light source under the object and forget about the lights on the scene altogether.

enter image description here

Or have no other emitters in the scene than the object generating its own luminescence:

enter image description here

and why not? another blend:

  • Those are good points. I did sort of get carried away with the size of the object and once I fixed the roughness of the glossy plane it was apparent I had to increase the lamp strength. However, I am trying to create the effect of luminescence in the dark. The hemisphere worked well, but is there a way to render the image without the background showing, i.e. transparent? – lakerice Nov 16 '15 at 0:31
  • As @cegaton suggested you can turn off the visibility of the camera (in Properties window go to the Object menu-->Ray Visibility panel-->uncheck the Camera checkbox). If you want to render with the transparent background check the Transparent checkbox (Properties window-->Render menu-->Film panel-->check the Transparent checkbox). More details here: blender.stackexchange.com/questions/1303/… – Paul Gonet Nov 16 '15 at 0:56
  • @Gonzou thanks that works! – lakerice Nov 16 '15 at 1:14
  • @lakerice updated answer... – cegaton Nov 16 '15 at 1:24
  • Sorry for the late reply; I've been trying out all those files and still trying to tweak it and experiment...but awesome setups and I am definitely getting closer to what I want. – lakerice Nov 17 '15 at 4:04

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.