6
$\begingroup$

enter image description here

It's so dark that the eyes are invisible.

Blend file:

$\endgroup$
  • $\begingroup$ The blendfile is different to the one in the pictures. Was this done on purpose? $\endgroup$ – Chickenator Nov 15 '15 at 8:57
  • $\begingroup$ Oh really? Don't remember I made any changes to this after writing the question. Does it matter much? $\endgroup$ – thododo Nov 15 '15 at 9:31
  • 1
    $\begingroup$ The glass has no no thickness. No back faces. So the light enters the surface and for the ray the thickness is infinity. Make the goggles from 2 pieces and model the lenses properly. $\endgroup$ – Jaroslav Jerryno Novotny Nov 15 '15 at 10:03
  • 8
    $\begingroup$ @thododo You're the one here asking for help. Try not to be rude. $\endgroup$ – iKlsR Nov 15 '15 at 15:19
  • 3
    $\begingroup$ There's something really strange about your file, I can't select the character or the goggles at all and they don't show up in the outliner. But it does look like jerryno is right, you need to give the glass some thickness. $\endgroup$ – PGmath Nov 15 '15 at 15:49
13
$\begingroup$

There are several things causing this:

Lens geometry

In the real world the lenses are likely solid objects separate from the goggles, merely fastened into place within the goggle frames by some means.

So model virtual lenses separately and put them in the virtual goggle frames:

  1. Start by making the goggle frames solid on their own, without any lenses:

    enter image description here

  2. Then model a separate lens mesh and put it in the frame. It shouldn't be connected to the frame (if you hover over it and press L, it and only it should be selected):

    enter image description here

  3. Ensure that the eye mesh doesn't intersect the lens:

    enter image description here

Caustics

Even with all that, a normal glass shader will still likely look dark without lots of samples. This is due to the fact that the only way for light to get behind and illuminate the eyes is by refracting through the lenses then reflecting back out, which is a fairly unlikely path for a ray to take. See this question for more detail.

To work around this, use a setup like the one described in How to illuminate the darkness inside glass objects in Cycles?:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks! How to lighten up object behind glass is definitely what I am looking for $\endgroup$ – thododo Nov 16 '15 at 3:48
  • $\begingroup$ Can I ask you about your lighting? It looks sooo nice!! Couldnt think my work can look this nice $\endgroup$ – thododo Nov 16 '15 at 4:13
  • 2
    $\begingroup$ @thododo The fact is I didn't touch anything. I simply enabled the existing light sources in your file; the lighting is all you :) $\endgroup$ – gandalf3 Nov 16 '15 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.