2
$\begingroup$

I'm trying to bake textures to a low poly, and here is a glitch I can not understand:

backed texture

My low poly unwrap is fully split, and the high poly use object mapping (cube map)coordinate which is a small cube.

Developing with OpenGL, I could imagine it comes from a bad texture coordinate for this particular vertex, but how could I verify that in blender?

Thanks in advance.

edit

Here is the uv's:

uv

I've set The island margin of smart uv, to make sure no overlapping occurs, but the glitch reapears . edit

here is the .blend:

edit Maybe theres a trick with Object Mapping Coord, or a bug.

I've tried with generated mapping, no problems, But I would have preferred object mapping, for uniformity across models.

$\endgroup$
  • $\begingroup$ You could open file with your mesh in Blender, select mesh, enter Edit mode and check if there are overlapping faces on UV map. See instructions on UV mapping mesh for more details. $\endgroup$ – Mr Zak Nov 11 '15 at 13:55
  • $\begingroup$ @MrZak: effectively, when I scale down the low polly unwrap, and put some space between faces, the glitch is gone. But the unwrap is done with seam at each side, and should normaly work without modification, maybe scaling up the model could help, I'll try. Thanks for the help $\endgroup$ – j-p Nov 11 '15 at 14:08
  • $\begingroup$ Can you include a screenshot of UV/Image Editor with mesh in Edit mode and all the faces selected ? Also if it's ok to have seams on each side you could use not manual unwrap method, rather then Smart UV Project (it just may be faster to set up). $\endgroup$ – Mr Zak Nov 11 '15 at 14:14
  • $\begingroup$ There could be some hidden problems here; probably, materials aren't assigned in desired way, or still there's a face/edge taking zero area in UV map; as of now it seems that there's wrong mapping on the lowpoly (mapping of the highpoly isn't important). Could you upload problem part of the file to blend-exchange.giantcowfilms.com ? $\endgroup$ – Mr Zak Nov 11 '15 at 16:03
  • $\begingroup$ @MrZak: ok done, I've also restart from scratch an even more simple one, but exactly the same problem arise $\endgroup$ – j-p Nov 11 '15 at 17:28
2
$\begingroup$

Finally, the way to solve this glitch is to set viewport shading to Rendered while baking.

enter image description here

This is clearly a bug in old rendering engine which seems solved in new Rendered viewport engine.

$\endgroup$
  • $\begingroup$ Please add some more details for people who may have this question in the future. $\endgroup$ – PGmath Nov 15 '15 at 16:04
  • $\begingroup$ I don't know much about blender source code, The OpenGL feature used in the rendered viewport are surely different from other simpler (and older) viewports. The Rendered Viewport and Baking are options surely linked in source code (I think they emerged at the same time), but without diving in source code, It's impossible to say more. $\endgroup$ – j-p Nov 15 '15 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.