4
$\begingroup$

I was attempting to bake the AO for a pumpkin model but it end up baking the top of the model as black. I have checked that the normals are pointing the correct direction and that theres no overlapping vertices.

enter image description here

To assure you that the normal is correct,

enter image description here

How can I resolve this issue?

$\endgroup$
1
  • $\begingroup$ How did you show the direction of the normals? $\endgroup$
    – Black
    Dec 1, 2017 at 12:52

1 Answer 1

7
$\begingroup$

Possible cause n°1

Some of your top faces normals are probably pointing inward, so is taking in account the inside of the pumpking and not the outside in the face-proximity calculation.

enter image description here

I would firtstly try to Recalculate Normals by selecting all the faces with A while in Edit mode and then press Ctrl+N.

You can display the normal vector of each face with the option you can see in the Property panel, in the Mesh Display section.

Possible cause n°2

One of your renderable objects in the scene is partially overlapped with some faces of the object you are trying to bake. Baking process takes into account also the objects in the neighborhood.

enter image description here

$\endgroup$
3
  • $\begingroup$ I have said in the OP that i have checked the normals. To assure you of that fact, I have added the normal view. $\endgroup$
    – DarkDestry
    Nov 11, 2015 at 8:47
  • $\begingroup$ In my case, it was a hidden object at the same point overlapping at the top. Thanks. $\endgroup$
    – DarkDestry
    Nov 11, 2015 at 9:39
  • $\begingroup$ I wasn't sure at first that you already checked normals because were mentioned the UV and not the faces. Glad it helped; I'll leave both possible causes, maybe someone will find helpful the first too. $\endgroup$
    – Carlo
    Nov 11, 2015 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .