2
$\begingroup$

If I double click a recent blend file icon, the version of Blender that it calls is an old one.

The file was created using 2.76, but if I double click it it runs inside 2.72b.

If I right click it and navigate to 2.76, it still opens with 2.72b... or at least that is what I think it did. Am I imagining things? (I have just tested and that is what happens)

If I double click the 2.76 .exe it opens 2.76, but if I go to the file icon, right click and then navigate to the 2.76.exe it opens in 2.72b

I have 2.72b in a completely different folder called ART. 2.73 and 2.76 are in the normal Blender Foundation folder right next to each other. So what is causing the system to jump to another folder to open 2.72b?

This isn't a problem, but seems bizarre.

EDIT: Windows 10. Yes, it is probably the O/S that is doing this, but it may mean that others have downloaded updated Blender, not overwritten the old install and are using the old version without noticing it. (It was a few weeks before I realised what was happening).

The thing to remember is to open Blender directly, check the splash screen and then File>Open.. the blender file. But finding the right version's icon is also hard because they don't include the version number in the icon. Perhaps it would be better if the icons change with each stable install the same way the splash screen changes.

I think I may decide to uninstall the old versions and see what happens.

$\endgroup$
  • 5
    $\begingroup$ I'd say this is more your OS related question. It depends, of course, but it seems that OS doesn't have necessary associations in order to confront file extensions with files (and so it always thinks there is only one version of Blender in your system). $\endgroup$ – Mr Zak Nov 10 '15 at 21:29
  • 4
    $\begingroup$ Sounds like you are on windows - try running blender 2.76 from a command line and use the -R option. If you are on *nix system then your PATH variable could cause one to be found one before the other, which blender should show the order they are found. $\endgroup$ – sambler Nov 11 '15 at 7:04
  • $\begingroup$ This is os dependent but a canonical answer would be nice. $\endgroup$ – iKlsR Nov 12 '15 at 14:14
4
$\begingroup$

For Windows:

On windows 7 right click on any .blend file and select open with and choose default program . Then use the browse button to navigate where the version you want of the blender program is on your hard drive, and select blender.exe as your default program to open this kind of file. To make the selection permanent check the box that says always choose the selected program to open this kind of file.

enter image description here

On Windows 10 right click on the file and use choose other app:

enter image description here

Then on the next screen navigate all the way to the bottom and click on look for other app on this PC

enter image description here

On Linux it's basically the same procedure:

Right click on the blend file and select Open with other application

enter image description here

then from there navigate to the folder the blender version you want to use:

enter image description here

enter image description here

On OSX

Ctrl Click on the icon and select open with->Other and select the blender executable you want to use.

enter image description here

$\endgroup$
  • $\begingroup$ As to what I tried to simulate the situation which is described by OP, it may not work always (or not for all users). It should, but windows is windows. For this case I think the solution of @sambler does the trick. $\endgroup$ – Mr Zak Nov 12 '15 at 16:35
1
$\begingroup$

I had to try a few more things before my .blend file would open as the latest version

Switching from 2.70 to 2.77a, just changing the "open with" did not work for me. I don't know exactly which of these suggestions fixed it, but I would also try the following in this order:

-Change the blender.exe to "blender 277.exe"

-Delete the old version information from C:\Users*yourname*\AppData\Roaming\Blender Foundation\Blender\2.70\config

-change "open as" option to new version.

$\endgroup$
0
$\begingroup$

Windows 10, open blend files with another blender version. Go to blender directory, the version windows 10 actually opens your blend files, just rename the directory (add some letters) then, right click on any blend file , choose another app.. go to the blender version you wish , and it will work this time as you wanted .

May the Force be with you! ;) mars.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.