5
$\begingroup$

I'm trying to create some objects in blender and I just installed it, but for some reason I have no option for smooth/flat shading in the tools? Im new to blender so I dont know where else to find it.

Any help is greatly appreciated

enter image description here

$\endgroup$
  • 1
    $\begingroup$ @cegaton, shading options should be available in Object Mode also (in Edit panel). $\endgroup$ – Paul Gonet Nov 10 '15 at 20:48
  • 2
    $\begingroup$ It looks to me like the object is not your primary selection. Try pressing "A" to deselect everything than right click the sphere to make it the "active" selection. Active selections usually have a brighter border yours does not look like the active selection. $\endgroup$ – David Prentice Nov 10 '15 at 20:48
  • $\begingroup$ @David Prentice No matter how many objects are selected you should still have this option visible in a Tool Shelf. Also with multiple objects selected you can apply shading type to all of them, so your solution isn't right. $\endgroup$ – Paul Gonet Nov 10 '15 at 20:53
  • $\begingroup$ @Densino what Blender version are you using? $\endgroup$ – Paul Gonet Nov 10 '15 at 20:57
  • $\begingroup$ In 2.76 even with nothing selected I have below 'delete' Join, Set Origin, shading -smooth flat, data transfer. $\endgroup$ – The Beachdancer Nov 10 '15 at 21:03
4
$\begingroup$

If the active object isn't a mesh, curve, or surface these options won't be available (thanks @Carlo). Right click on an object to make it active. Use ⇧ ShiftRMB RMB to make an object active while maintaining the rest of the selection.

It's somewhat rare that you end up completely without an active object, but it can happen e.g. when switching between layers.

$\endgroup$
  • 1
    $\begingroup$ I would add that the active object must be "shadable" (e.g. cameras, empties...are not). $\endgroup$ – Carlo Nov 11 '15 at 10:39
1
$\begingroup$

In short, you need to unselect everything by pressing a and then right-click the sphere. Then you'll have shading options.

The long answer is: Blender does a weird thing with "active" versus "selected" that I haven't seen done anywhere else. It's not complicated, but it's hard to figure out if you don't know what's going on. The dark orange outline means that the sphere is "selected" but not "active." Multiple things can be highlighted at once, but only one of them is "active." The "active" one will have a bright orange outline. The "active" one is the one whose properties will be showing in the properties panel, and whose name will be in the bottom left of the screen. For actions that can't be applied to all the highlighted objects, that action will be applied to the one object that is "active."

If you have many objects highlighted, you can change which one is active by holding shift and right-clicking different objects. If you right-click a "selected" object, it will become the "active" object. If you right-click the same object again, it will usually unselect it, and it won't be highlighted at all anymore. At this point, there will be no "active" object.

When you press a to unselect, it doesn't change the active object. So if you unselect with a and reselect with a again, you STILL won't have an active object.

Hope that helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.