4
$\begingroup$

I selected File > Import > Images as Planes, and chose a 700 kB png from the file system screen that pops up (in Blender 2.76). The first time nothing happens, on later tries it gives me the errors shown in the screenshot:

error message

I've tried now with different images, same thing. Definitely nothing is added to the scene - nothing shows up in the Outliner. It is a new file nothing in it but a lamp and a camera.


Edit: This was a temporary problem with the Ubuntu launchpad ppa version of Blender. It has now been fixed.


The file is here

The png file can be downloaded from here, and here is a version:

png file to import What should I do here?

$\endgroup$
  • $\begingroup$ Trying to do it in any of my blender files now gives me the same error, for any of the images I've tried, jpg and png. $\endgroup$ – kim holder Nov 10 '15 at 2:11
  • 1
    $\begingroup$ seems like it's time to file a bug report. I can't import images as planes in blender render. i.stack.imgur.com/VLOHO.png $\endgroup$ – cegaton Nov 10 '15 at 2:13
  • $\begingroup$ to file a bug report blender.stackexchange.com/questions/1377/… $\endgroup$ – cegaton Nov 10 '15 at 2:14
  • $\begingroup$ Not having any issues with 2.76.2, import images as planes "version": (2, 0, 4), have you done a make install recently, the line numbers on your error message don't appear to add up. $\endgroup$ – batFINGER Nov 10 '15 at 6:43
  • $\begingroup$ @batFINGER I don't know what you mean by a make install. I did a regular update after encountering the problem, to 2.76b, and the problem has persisted. My OS is Ubuntu, maybe it doesn't happen in versions for other platforms. $\endgroup$ – kim holder Nov 10 '15 at 7:32
1
$\begingroup$

I had the same error:

Apparently images can't be in the same context as the blender file (note on the report error, first line starting with File, context is written within the parenthesis).

So create another file separated from where the blender file is and import your images from there. It worked fine for me.

$\endgroup$
  • $\begingroup$ What do you mean by the same context? It was in a different folder... $\endgroup$ – kim holder Nov 22 '15 at 22:23
0
$\begingroup$

I'm running Linux Mint, had enabled the repository for Blender, and had the same error as you.
I tried to used the official download and now I can import images as planes without problem.

Have no clew what the problem may be with the repo version, but works easily with the official version.

$\endgroup$
  • $\begingroup$ I did the same thing. I got an email from Thomas Schiex a few hours ago that there is a new version. I've tested on it, and the problem is resolved. $\endgroup$ – kim holder Nov 22 '15 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.