8
$\begingroup$

I'm trying to keep my reference image that I important as a plane in Material mode while I can still adjust the object I'm modeling by switching between Wireframe and Solid (by using Z). Every time I hit Z the reference image goes to wireframe/solid. How do I go about this? Google is yielding no results, or I just don't know the proper terms to use for searches. I am using Blender Cycles.

$\endgroup$

3 Answers 3

9
$\begingroup$

In the object properties there is an option called maximum draw type. Set this to wire. It will display the object as wire like the wire view mode, although a handful of things are different regarding selection in edit mode and such.

enter image description here

If you want to select the object like in wireframe mode as well, you can turn off limit selection to visible:

enter image description here

$\endgroup$
5
  • $\begingroup$ This does not give all the benefits of working in wireframe mode, however. If you try to select verts from the back side of the model with box select, they will not be selected. The points are still occluded by the object, despite being able to see them. If you change to wireframe mode, the points will be selectable again. I want to bring this up with the developers and see if we can get it changed. $\endgroup$
    – Italic_
    Nov 8, 2015 at 19:38
  • $\begingroup$ @Italic_ The OP's issue was not being able to see the background issue. Limit selection to visible can also be turned of if the OP wants to have the selection ability of wireframe mode. Side-note: Because we have the limit selection to visible option, I would not be happy to have the maximum Draw Type have the same selection modes as wireframe, since how would, if I wanted to, Have the object in wireframe and limit selection to visible functioning. I wouldn't take this up with the devs. $\endgroup$ Nov 8, 2015 at 20:04
  • $\begingroup$ Since there's the limit toggle, I guess it wouldn't be necessary. It's not very intuitive, though, because wireframe only allows selection through the whole model, not occluded selection, so by allowing the occluded selection it breaks convention with the other mode and UI. Telling us both are wire is not entirely true because they don't behave the same. $\endgroup$
    – Italic_
    Nov 8, 2015 at 21:48
  • 1
    $\begingroup$ @Italic_ No they don't behave the same... I never meant it like that however, since it could be an issue, I will point it out. $\endgroup$ Nov 8, 2015 at 22:49
  • $\begingroup$ Looks like a good edit. Thanks for clarifying. $\endgroup$
    – Italic_
    Nov 8, 2015 at 22:57
6
$\begingroup$

Another option is to use an Image Empty for your reference image. Hit Shift+A > Empty > Image. Then go the empty's settings in the properties view and open the image you want to use. The empty will display the image no matter what viewport shading mode you are using.

enter image description here

$\endgroup$
0
$\begingroup$

For 2.8 and up:

  • Click the object
  • Click to Object Properties
  • Drop down Viewport Display
  • Drop down Display As
  • Choose how to display the item while in the viewport

Screenshot: enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .