2
$\begingroup$

I need to do the following - import two different Collada-files, join them into one and combine their textures to one texture. So, the output should be one Collada file with just one texture. I am trying to bake textures like here: How to combine two different textures into one but get some strange result in the baked texture. Just for example - here is the joined object with two materials (and two textures): Joied object with two materials and textures

When i try to bake the textures I switch to the Edit mode, select everything with A, push Bake in the render menu and get the following strange baked texture:Baked texture

What approach should I choose to make the correct texture and material?

I will describe the way I worked step-by-step:

  1. Load the first and the second model
  2. Position the models side-by-side (just like on the first screenshot)
  3. Created a new UV Map
  4. Created a new image in UV Image Editor with default size (1024x1024)
  5. Created a new material for the baked textures
  6. Went to the Texture tab with the material selected and in the material textures tab created a new texture
  7. In the texture selected the image created in step 4
  8. Went to the Render Tab
  9. Switched to the Edit Mode, selected everything with A in 3D View.
  10. In the UV Image Editor switched to the image to which I want everything to bake
  11. Push the Bake button in the Render Tab
  12. Got this strange result.

    What I have missed?

Thanks in advance!

$\endgroup$
  • $\begingroup$ Is the object UV mapped ? Did you join them before baking ? $\endgroup$ – Mr Zak Nov 3 '15 at 20:37
  • $\begingroup$ Yes, the object is UV mapped. I join the objects in the beginning and then create a new UV Map just like here blender.stackexchange.com/questions/32677/… $\endgroup$ – Sergio Nov 3 '15 at 20:44
  • $\begingroup$ Did you create another one material especially for baked texture ? And also did you select in all the materials which UV map should they use ? It should be their own UV map for their own materials, and new UV map for the baked texture. $\endgroup$ – Mr Zak Nov 3 '15 at 21:17
  • $\begingroup$ I will describe the way I worked step-by-step: 1. Load the first and the second model 2. Position the models side-by-side (just like on the first screenshot) 3. Created a new UV Map 4. Created a new image in UV Image Editor with default size (1024x1024) 5. Created a new material for the baked textures 6. Went to the Texture tab with the material selected and in the material textures tab created a new texture 7. In the texture selected the image created in step 4 8. Went to the Render Tab 9. Switched to the Edit Mode, selected everything with A on the left viewport $\endgroup$ – Sergio Nov 4 '15 at 5:19
  • $\begingroup$ 10. On the right viewport ((UV Image Editor) switched to the image to which I want everything to bake 11. Push the Bake button in the Render Tab 12. Got this strange result What I have missed? $\endgroup$ – Sergio Nov 4 '15 at 5:26
3
$\begingroup$

When objects were separate, they had their own UV maps as they should have been textured. Let's assume these are called "UVmap" as by default.
Objects had their materials, I assume they were called "Material_1" and "Material_2"; let's call the new material created esspecially for the bake as "Material_Bake".

After joining objects create new UV map and call it "UVmap_For Bake". Make some arrangements on that new UV map so faces not overlap there (the easiest way is to press Ctrl + P with everything selected that you'd like to rearrange while in UV/Image Editor).

For "Material_1" and "Material_2" in Texture tab, Mapping scroll set Map option to "UVMap", so that the original images are mapped using original map.
For "Material_Bake" choose in Texture > Mapping > Map your new UV map "UVmap_For Bake" so that baked texture to be mapped on the both objects with arranged map:

screenshot


It seems in your file "BakedMaterial" was assigned to all the model's faces, therefore others didn't affect on the final result.
The original materials should be assigned to those parts of mesh which they were created for.
After joining, you create that new material, but don't assign it to anything or you'll get circular reference in texture stack, empty result, rewritten images etc. Just create it and proceed to the next steps. You can look at 2 ways of how materials were assigned below.

enter image description here enter image description here

It's most likely that you won't get expected result of baking in the second case.

The file below is the one with the result of incorrect baking, slightly edited. Open it, press Bake and enjoy. It'll bake generated images of one color (unfortunately your files weren't packed) into "Texture_For_Baking" texture.

$\endgroup$
  • $\begingroup$ I did not understand the step with Ctrl+P. In what mode should I press it? When I am in Edit mode and select all faces and press Ctrl+P it asks about "Make Vertex Parent" - if I choose this option it shows an error... $\endgroup$ – Sergio Nov 4 '15 at 14:46
  • $\begingroup$ Tried your method and get another result from my previous, but still not correct. Here is the screenshot - the object with applied baked material and the texture itself: Screenshot(db.tt/yooBAlZ2) $\endgroup$ – Sergio Nov 4 '15 at 15:05
  • $\begingroup$ Here are the source Colladas, Blender file with just two colladas imported and Blender file with the result of not correct baking: db.tt/Tm1uV107 $\endgroup$ – Sergio Nov 4 '15 at 15:28
  • $\begingroup$ The point is that I did not assigned baked material to the model before baking. I assigned it just to demonstrate that it is not correct. I would like to remind that the result I want to achieve is to get the model with just one texture which I will export to Collada (which should be with just one texture). So I need the way to merge two objects, merge their textures to one texture (material) to get the correct result - collada with just one texture. And it is still unclear for me how I will achieve the desired result. Possibly I miss some details which prevent me from understanding $\endgroup$ – Sergio Nov 4 '15 at 18:35
  • $\begingroup$ 1. I assume that everything included in the sent blendfile was used in the workflow if not stated otherwise. As it's not, you simply confuse others because they aren't able to guess. 2. What's wrong with the result with "BakedMaterial" ? It allows you to use one texture with one material, which you should setup. Note that you didn't said anything about your edited file - it does just that (delete those 2 materials&save image to see that). 3. As you don't get desired result it's definitely true that you do something in a wrong way as baking from several materials does works. Good luck! $\endgroup$ – Mr Zak Nov 4 '15 at 19:27
0
$\begingroup$

Finally, I have found the correct way for baking textures for my files. There is a great tutorial here: https://youtu.be/Tj-S5QAac3U Following all steps exactly as was shown in the video I got the correct result just in 10 minutes. Hope, this will save time to someone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.