3
$\begingroup$

Im trying to create a cyclinder with the bottom and top rounded but when i use the Sub divison modifier it leaves these creases at both ends and if i use a loop cut to smooth it out it makes the object to flat at both ends and not rounded how can i fix this?enter image description here

$\endgroup$
  • $\begingroup$ Related - blender.stackexchange.com/questions/734/… $\endgroup$ – Mr Zak Nov 1 '15 at 20:38
  • $\begingroup$ @MrZak I think he is trying to not have sharp edges. $\endgroup$ – PGmath Nov 1 '15 at 21:30
  • $\begingroup$ @PGmath yes, probably it was better to say the main thing is topology. $\endgroup$ – Mr Zak Nov 1 '15 at 21:36
2
$\begingroup$

Those ugly creases are caused by the n-gon cap. The Subsurf modifier works best with quads and doesn't work well at all with n-gons.

Here are two alternate methods of filling the cap which produce quads, and thus much better subdivision modeling.

enter image description here

  • The first example was made by selecting the n-gon face and then hitting E (exturde) and then S to scale the extrusion inward. You could move the extruded part up to make the top less flat.

  • The second example was made by joining half the opposing vertices, making a quad fan. This could also be done by using the Grid Fill option. Again, the central vertex could be lifted up to make the top more round.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.