2
$\begingroup$

I'm currently working on a small creek for learning purposes. I've built the main terrain and am now stuck on the fluid animation.

This is my project so far:

Project at frame 1

As you can see, there are two inflow sources (the two white blobs) and one outflow (the white cube at the left side). The domain is already baked with a low resolution, the screenshot above shows the scene at frame 1, everything seems to be working.

However, from frame 2 onwards, the inflow cube at the right side doesn't seem to produce an inflow, it just looks like this:

project at frame 2+

Both inflow sources are in the domain, both have a starting velocity pointing towards the correct direction. It has worked before with only one inflow source (the one that isn't working right now), however I'm not sure what I could have done to break it. I've tried deleting the other inflow source, but that didn't help. Any ideas what's causing this / how I can fix it?

Thanks!


I'm following this tutorial on Youtube in case that matters. I'm a beginner in Blender, so I'm not sure if all relevant information is visible on the screenshots. If you need me to provide additional information, please let me know!

$\endgroup$
0
$\begingroup$

First of all, you should bake the sim with a higher resolution. The resolution is not just about quality, it determines how the fluid acts. Using a resolution as low as 44 just doesn't make sense.

That being said, one possible reason why the inflow does not work is that it may be too close to the edge of the domain. Inflow objects need some space around them.

While the general wisdom is that the domain should be as small as possible, this can cause problems. Increasing the domain size should always be part of the trouble-shooting process when a fluid simulation won't work properly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.