5
$\begingroup$

Why don't these add up to 1?

I have seven RGB Input Nodes that are greyscale and have Value of the following amounts:

0.18333
0.2
0.15
0.18333
0.1
0.06667
0.11667

I would expect these to add up to 1 and become white, but that is not what happens.

Instead I get a dull grey (#686868): grey color Why is this? (There are no other lights in the scene.)

This is my node set-up:

Something isn't adding up

Next I tried using Add Shaders to see if that would make a difference, but it did not:

Still not adding up...


Update & semi-answer: This works ↓ (but I don't know why)

I had been adding the Value:

Value input

I should be adding the RGB if I want them to add up to white:

RGB input

I didn't realize that the value is sort of a result of the RGB. Nodes that add are adding the RGB, not the Value.

(I'd be happy to accept an answer that explains how the two are related.) The answer is probably in here somewhere.

$\endgroup$
1
$\begingroup$

Go get white you have to pass something that will increase the color. For example... You have add and a factor of 1.000. This means you are not mixing the colors, but instead using one input of the node.

Just curious though, what are you trying to do? Why not just use a white shader?

$\endgroup$
  • $\begingroup$ Your suggestion did not work. I need more explanation. Moving the sliders to 0.5 gives a result of #4B4B4B. Moving them to 0 gives #2F2F2F. Actually, even adding RGB didn't work! (gives #E7E7E7) Re:"What are you trying to do?" This is part of an experiment to separate the spectrum of visible light into seven proportionate bands, then refract each one at a different IOR. These will need to be recombined with Add shaders in the final project (think of a prism), but I noticed colors aren't being added back up to white so I have to find out why. $\endgroup$ – Mentalist Nov 1 '15 at 5:23
  • $\begingroup$ Never mind the part about RGB not working - for that mix I had forgotten to change the Emission Shader's Value to 1 (It's 0.906 by default). Then when I combine 3 Emission Shaders of solid red, green, and blue via two Add Shaders it works. But actually this gives a hint to the nature of the problem - a discrepancy between RGB amounts and the Value amount. I think the simple answer is that adding RGB and adding Value are different things. A MixRGB Node and an Add Shader both add RGB values, not Value. I would like to know how RGB and Value correlate though (which may not be Blender-specific). $\endgroup$ – Mentalist Nov 1 '15 at 5:44
  • $\begingroup$ Glad I could help. :) Sometimes, actually many times; it doesn't work quite how we expect and with adding or tweaking things makes it work. Try playing with a variety of node setups or lights too. I'm sure it can be done, but as I mentioned it's finding that magical combination. $\endgroup$ – probie Nov 1 '15 at 5:58
  • $\begingroup$ I'm sure you thought about this too, but the presence of all colors will give black where with light you will get white. $\endgroup$ – probie Nov 1 '15 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.