5
$\begingroup$

A simple example what I like to do:

enter image description here

In this workflow I am using the "smooth vertex" operator to smooth the edge loops. For my desired result I need to delete the bridge edges to smooth only the loops, as the operator takes the connected mesh into account. The operator seems to ignore the hidden property of mesh parts, so I can't get it done without deleting and regenerating the bridge edges. That's fine for this simple example. But for more complex models with worse topology, where it's not as easy to recreate the deleted edges it can become a lot of work.

So my (actually two) questions are:

  1. Any suggestions to smooth the loops in the above manner without affecting the other mesh?
  2. Is it desired behavior of the smooth vertex operator not to take the hidden property of verts/edges/faces into account or is it just not implemented yet?
$\endgroup$
  • $\begingroup$ You could try to add Laplacian Smooth modifier with desired vertices assigned as a vertex group (in modifier properties) to limit its influence on them only. Other similar modifiers like Smooth or Corrective Smooth most likely will give you result from the right part of your scheme and so won't be appropriate. $\endgroup$ – Mr Zak Oct 30 '15 at 18:51
1
$\begingroup$

to fix on the Z dimension, use scale, S Z 0

Then you can use "to sphere" ALT SHIFT S and dragging to the amount or pressing 1 to get 100% circle

this after fixing Z as above

like

enter image description here

[edit] Now, I see from your "desired" that the loops are not necessarily on the global XY plane, so my method above is not entirely sufficient.

I found a way to fix that, too, maybe you know this already but: after "scaling Z 0" your edge will be aligned to XY, as said, which is not what you want. Unfortunately there is not (afaik) a method to directly achieve what you want, but you can do this:

  1. before "scaling Z 0", add a new object, a simple circle, and try to put it on your desired final position.
  2. then, edit you more complex shape with jagged edges, do "scaling Z 0"
  3. then, with that now Z scaled edge loop, view it from the side
  4. then activate snapping to edges (header icon list next to magnet)
  5. now, in edit mode from the side view, rotate/move the edge loop, snapping it to the "simple circle" you placed before, even acting from other sides.
  6. when your corrected edge loop is now aligned as it should, you can then delete the simple plane you adde just for this scope. Tell me if you need a more detailed example.

[edit2] after your comment, I add some more image about point 1-6 just above:

As in your example the shape has jagged edge loops not aligned do any global plane at all: you add a simple circle (on the left) and place it where the final edge loop needs to stay

enter image description here

like this enter image description here enter image description here

then, you scale Z 0 the jagged edge loop, that also align it to XY

enter image description here enter image description here

then, using the snap to edges tool, you rotate it to align to the previously placed simple circle which is "in the right position"

enter image description here

so now your edge loop is again in its original position (you just need to use "to sphere", as said at the start, to smooth it completely) and you can remove the simple plane just used as reference

enter image description here

$\endgroup$
  • $\begingroup$ Yes, the vertices of the loops are not always in the same plane, so scaling them to the same plane is not an option. I guess I should have shown that clearer in the example. $\endgroup$ – Mr. Mach Oct 30 '15 at 14:06
  • $\begingroup$ I updated the example image in my question to have the loops a little less noise and more shape, to see that the loops verts are not on any plane at all. By using "scale Z 0" you force them to. Sure after the rotation they are not on the global XY-plane anymore, but they are still on a local same plane. If I find the right button, I'll attach the .blend :) $\endgroup$ – Mr. Mach Oct 30 '15 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.