4
$\begingroup$

I'm following a tutorial on YouTube but my model (and many others') turn brown when rendering (cycles render) instead of a wood texture. Here's what it looks like:

enter image description here

Interestingly, the text does have the texture:

enter image description here

EDIT Starts now: Here's the shader nodes:

enter image description here

And here's the .blend file!

I think I found the problem: instead of the texture - the same colour as the rendered model in the 'Render Layers' node, how do I fix this? This also happened after I started added the animation.

enter image description here

$\endgroup$
  • $\begingroup$ Try selecting your model and applying it's scale (ctrl-A). It might be the proper wood texture, but it's scaled up so big that you can't see the details. $\endgroup$ – ajwood Oct 29 '15 at 13:41
  • 6
    $\begingroup$ Is your box UV mapped? $\endgroup$ – TLousky Oct 29 '15 at 13:43
  • $\begingroup$ I did use compositing. I edited the shader nodes so there was a connection from Colour in Image Texture to Displacement in Material Output. This was supposed to add some 'depth' to the texture. By the way, here is the tutorial video. $\endgroup$ – Marine Biologist Oct 29 '15 at 13:48
  • $\begingroup$ @MarineBiologist What type of mapping coordinates are you using? It looks like you don't have any. $\endgroup$ – PGmath Oct 29 '15 at 14:11
  • $\begingroup$ @PGmath I used a material to texture it. In the 'color' section, I put 'Image Texture' and loaded up the image that I was going to use. There is a reason why are tagged my question as 'cycles'. $\endgroup$ – Marine Biologist Oct 29 '15 at 14:20
0
$\begingroup$

It turns out the answer is quite simple. All I needed to do is just go to the modifiers tab, scroll down to the 'Explode' section (I used a 'Quick Explode' animation, don't even ask me why it caused such a problem) and uncheck 'Cut Edges'. Thanks for the support and ideas, though, as this wouldn't be here for people who would need it in the future without all of your support.

Explanatory image

Source:

$\endgroup$
-1
$\begingroup$

You didn't UV unwrap your object. I run into this as well. Just go into Edit Mode, select everything and hit 'U' to unwrap. That should fix everything.

$\endgroup$
  • $\begingroup$ Does this take into account that I'm using a quick explode animation? $\endgroup$ – Marine Biologist Nov 7 '15 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.