2
$\begingroup$

I have a simple scene setup:

Cube and a Sphere lighted decently. Blender Internal renderer. Shading - GLSL Viewport Shading - Material. I add the Scene in VSE and use Open GL Preview and Sequencer Preview Shading to Material.

Now when I hit the Open GL render button in the 3D View the scene renders with good anti-aliasing of the objects edges. But when I hit the Open GL render button in Video Sequencer Editor the objects are rendered with jagged edges.

Why is that difference and is there a way to Open GL render in VSE with proper anti-aliasing?

Thanks!

$\endgroup$
3
$\begingroup$

OpenGL rendering in the VSE ignores the AA settings because it just pipes the viewport output through while

Render -> OpenGL Render Animation

is more like an own render engine utilizing OpenGL. The OpenGL AA setting is only used by that "engine".

You can still get AA by setting the resolution of your original scene way bigger (like 400%) than the VSE scene. Blender will first render the scene really big in OpenGL and then scale it down in the VSE, wich essentially results in antialiasing.

$\endgroup$
  • $\begingroup$ Has it been fixed or something ? Now I'm trying to disable anti-aliasing using the VSE but I can't. $\endgroup$ – ChameleonScales Apr 24 '17 at 16:29
  • $\begingroup$ I found a way to disable anti-aliasing in Blender 2.78 openGL renders : enable viewport ambient occlusion and set the strength to 0 (unless you actually want ambient occlusion in your render) $\endgroup$ – ChameleonScales Apr 24 '17 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.