2
$\begingroup$

a newbie question that has probably been answered before, but I couldn't find a definitive answer:

I'm trying to render a simple glass container with some dark liquid in it, but I'm getting weird "seams" on the round edge of the container in rendered image. It's as if the normals are somehow miscalculated and causing the refractions to render incorrectly. This should not be the case, as I have recalculated the normals for the outside, as you can see from the image. I used the Solidify modifier to get the container, original mesh only had single faces for all the sides (and the rounded end) minus the top face, no other modifiers used. The liquid is a separate object that I created by copying the inside of container.

So, what's causing those seams to appear and what can I do to get rid of them?

The problem, circled with red: enter image description here A view from my editor, as you can see, normals seem to be OK: enter image description here

$\endgroup$
  • 2
    $\begingroup$ Looks to me as there are some interior faces. $\endgroup$ – Jaroslav Jerryno Novotny Oct 22 '15 at 17:05
  • $\begingroup$ I tried selecting all interior faces and hitting delete, but nothing was removed ant the problem persists... $\endgroup$ – JonK Oct 22 '15 at 17:20
  • $\begingroup$ Assuming that you are using a default Glass shader, do the "artifacts" persist even if you lower the IOR value to 1? What happens if you use a trasparent shader instead? $\endgroup$ – Carlo Oct 22 '15 at 17:35
  • $\begingroup$ Turning IOR to 1 results in the glass turning completely invisible in render. Using transparent shader looks like it should I think, it has no artifacts like the glass does. $\endgroup$ – JonK Oct 22 '15 at 17:40
2
$\begingroup$

I think you simply forgot to turn on smooth shading. See these examples (looks very similar to your issue):

Flat shading Flat shading

Same geometry with smooth shading (and EdgeSplit modifier) enter image description here

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Yeah, I intentionally left smooth shading off, since I did not want it to affect the square parts of my container. It didn't occur to me that it was actually the cause for those artifacts. I then enabled smooth only for the round part of the object, and that fixed the problem $\endgroup$ – JonK Oct 22 '15 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.