3
$\begingroup$

I was wondering if anyone knows how to make it so the animation renders with a transparent background so in the video editor, I can overlay "Scene" and it will have a transparent background, thanks.

$\endgroup$
3
$\begingroup$

By default, if you add a scene to the VSE, it comes in with alpha already, so you shouldn't need to do anything else. If you are rendering the scene, you'll need to enable transparency under the render settings. Go to your render tab, find the "film" section, and enable transparency. Next time you render, the VSE will update with the transparent image. Likewise, if you turn off transparency, the VSE will update with an image without any alpha. The viewport defaults to transparent, no matter the settings in the viewport or in openGL render settings.

Once you have the scene in the VSE, you need to change the strip's color blending mode to "alpha over" - then you can put that strip over your other media and the scene will be overlaid.

First is Cycles, then BI. (Thanks Sambler)

VSE transparency

BI

| improve this answer | |
$\endgroup$
  • $\begingroup$ That applies to cycles, if you are using blender render then instead of transparent under film you need to choose transparent alpha mode under shading. $\endgroup$ – sambler Oct 22 '15 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.