5
$\begingroup$

I have a plane "shooting" particles and I want those particles to stick to wherever they land and stay sticked. It does that on perfectly horizontal faces (the top of the cube) but if they land on a face from the sides they slowly slip off.

sliding particles

This is because of gravity but if I turn it off the particles will just fly off infinity in the direction they are "shoot".

The cube has these settings in the its Collision physics: Stickiness: 10 Particle damping factor: 1 Particle Friction: 1

How can I make them stick to the side faces and stay there?

Using Blender 2.76

$\endgroup$
  • $\begingroup$ How about Die on Hit, and render "died" on the particle system? $\endgroup$ – batFINGER Oct 21 '15 at 18:08
  • $\begingroup$ That works good for non-moving objects but I have some that move and in those the dead particles won't move along with the object. $\endgroup$ – The Berga Oct 21 '15 at 18:18
  • $\begingroup$ maybe give the cube a field attraction using surface? $\endgroup$ – 3pointedit Jul 21 '18 at 13:47
10
+25
$\begingroup$

It can be done by using an addon called Animation Nodes.

enter image description here

The basic concept here is to get the location of each particle unit by the moment they die on hitting the collider. Then parent them to it immediately.

Here is a template setup:

(2018-07-21 updated, compatible with AN2.0)

How to Use:

  • Open the attached file;
  • Download the addon from the link above, then install and enable it;
  • Replace Eimtter and Collider object input on related nodes.
  • Go to frame 1, play animation.
$\endgroup$
  • $\begingroup$ I know, it may involve a totally new tool. I'll see what I can do if additional guide needed. $\endgroup$ – Leon Cheung Feb 6 '16 at 8:45
  • $\begingroup$ Do you mind updating that answer for more recent versions, this is related to this Question. Maybe more details such that it is useful without the the blend file. $\endgroup$ – Omar Emara Jul 2 '18 at 17:01
  • $\begingroup$ @OmarAhmad Will do later asap. $\endgroup$ – Leon Cheung Jul 4 '18 at 2:35
  • 1
    $\begingroup$ @OmarAhmad Finally find some time to find what's going on. :) $\endgroup$ – Leon Cheung Jul 21 '18 at 12:14
0
$\begingroup$

One reason could be your particle cache step. Setting it to one frame should at least lessen if not stop the sliding.

Essentially the eighth step in here:

How can I simulate powder with a particle system?

$\endgroup$
0
$\begingroup$

in the Scene tab you can turn off gravity, just untick the checkbox. I have some issues with particles bouncing off for high speed and grazing incidence angles but otherwise works fine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.