5
$\begingroup$

I have a bunch of boxes flying apart in Cycles, and I'm using the Vector Blur node for motion blur. Nothing's blurring.

It's the simplest compositor setup: RenderLayer Image/Z/Speed goes to Vector Blur node Image/Z/Speed, Vector Blur node goes to Comp.Out and Viewer.Out. I've tried all sorts of settings on the VB node, but nothing changes. What have I not set up?

Blend file: https://www.dropbox.com/s/8k6n3cr3wu2iwqo/logo_match.blend?dl=0

$\endgroup$
  • $\begingroup$ Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Oct 20 '15 at 21:43
  • $\begingroup$ Trying to remember how (blush)... Done. $\endgroup$ – OroNZ Oct 20 '15 at 21:46
  • $\begingroup$ @Carlo Be careful when re-uploading .blends. In general it's probably not as important to upload question .blends compared to answers. $\endgroup$ – gandalf3 Oct 20 '15 at 22:13
  • $\begingroup$ Uh, sorry @gandalf3! I'll carefully read that post. Thanks for the advice. $\endgroup$ – Carlo Oct 20 '15 at 22:18
5
$\begingroup$

This is because the vector pass can't "see" through transparent (glass) objects; in this case all it sees is the lens object, which is remaining motionless relative to the camera.

To render with motion blur in this situation, you'll have to use Cycles' built in motion blur. Enable it in Properties > Render settings > Motion Blur:

enter image description here

And remove the vector blur node in the compositor.

$\endgroup$
  • $\begingroup$ Oh you are KIDDING me :( Drat, drat and double drat. OK, I'll re-do the scene and teleport the lens into shot once the vector blur's done its job. DRAT. But thanks :) $\endgroup$ – OroNZ Oct 20 '15 at 22:35
  • $\begingroup$ @OroborosNZ Any reason you need to use vector blur? Cycles blur should just work™ out of the box $\endgroup$ – gandalf3 Oct 20 '15 at 23:58
  • $\begingroup$ Cycles Motion Blur does work, and well.... I'm just trying to shave render time, and Vector Blur's faster. I don't have a comp I can dedicate to Sheep-it, and I don't really have much idea around sending files to a render farm. So I'm doing my best to shave seconds, and finding my own line between "noisy output" and "artistically-intended, post-modernistic style" :P $\endgroup$ – OroNZ Oct 21 '15 at 0:27
  • $\begingroup$ OK, tried the lens teleport approach - but now there's a savage light dip when the lens goes in front of the camera. RAAAGE. Looks like Motion Blur IS my only option, or I'm spending hours/days trying to find out why a perfect virtual lens is also absorbing light =>:-[ $\endgroup$ – OroNZ Oct 21 '15 at 0:42
  • $\begingroup$ @OroborosNZ The lens's glass shader color is set to .8 white. Setting it to 1 should fix it $\endgroup$ – gandalf3 Oct 21 '15 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.