0
$\begingroup$

Using cycles don't understand how to scale my uv so that it looks right on the model but remains small enough to fit in the uveditor image so i can bake it properly. The texture image is bricks and is about 500x500. Im using an image size of 4096x4096 in the uveditor window.

I have to scale the uv up so large to make the bricks look right that it's way to big to fit in the image size i want to bake at. Maybe my texture is too large or maybe cycles isn't the best way to do this?

Here are some pictures

Here is what the uvs look like right now

enter image description here

Now i scale the uvs up to make the bricks look right on the model

enter image description here

And this is where im stuck I want to bake a texture map here but the uvs are much too large to fit in the image at this size? Do I have to just increase the size of the image or find a smaller texture image? Seems like there would be a way to adjust the texture image size or tiling so that you dont have to scale the uv so big to make it look the way you want but instead decrease the size of the texture. Does something like this exist or is there another answer im over looking?

$\endgroup$
  • $\begingroup$ It seems to me the only question you ask is the sentence in the very end of your text. In this case, to make all the UV map islands fit texture space (that box in the UV/Image Editor in the middle) select islands and press Ctrl+A. $\endgroup$ – Mr Zak Oct 18 '15 at 19:11
  • $\begingroup$ I think it would be useful if you could add some images to illustrate each step of the process you are doing so we can see where you might be going wrong. $\endgroup$ – Ray Mairlot Oct 18 '15 at 20:00
  • $\begingroup$ That little box needs to contain all of your texture. So if the tiling is too big, you can make your image larger (have more tiling) relative to your UV Map. ...If I'm understanding your situation correctly. $\endgroup$ – Mentalist Oct 19 '15 at 2:57
  • $\begingroup$ got it just needed to scale with the mapping node this tutorial explained everything if anyone else comes looking for this issue youtube.com/watch?v=sB09T--_ZvU $\endgroup$ – Rcprobot Oct 19 '15 at 10:48
1
$\begingroup$

I think what you might be really looking for is using a different set of UVs to bake and a different set to map your source texture. This is a cleaner solution that will allow you more flexibility later on, and will also work nicely if you want to use texture atlases (bake many objects to one large texture).

This way you can scale the brick UVs without affecting the UVs used for baking. It's in Properties panel > Object Data tab > UV Maps > [+] button. You can have one UV set for the bricks ("brick uvs") and one for baking ("baking uvs"). Set the "baking uvs" as default for rendering (camera icon).

Then in Node Editor, instead of using the Input > Texture Coordinate node's UV output as you are now (this only uses one default UV layout) you can choose Input > UV Map, this lets you choose which UV layout you want to get your UVs from - pick "brick uvs" as input for your texture.

If you do this correctly you should be able to freely adjust the UVs for the bricks without affecting the UVs you use for baking.

Update: see this file for an example http://www.pasteall.org/blend/38727

$\endgroup$
  • $\begingroup$ I tried this and came up with semi good results I scaled uvs instead of using mapping node then baked to another texture image node with the original uvs mapped to it the size came out perfect but the actual bake only contained a diffuse color not the actual texture so now the size is good which was the initial problem but now the texture doesnt show in the bake. $\endgroup$ – Rcprobot Oct 21 '15 at 16:10
  • $\begingroup$ Imgur $\endgroup$ – Rcprobot Oct 21 '15 at 16:13
  • $\begingroup$ It's hard to say what exactly went wrong, my guess is you didn't select "Bake Type: Combined" in Bake options. I have updated my answer with a .blend file with a correct setup for your reference. $\endgroup$ – redonwhite Oct 22 '15 at 12:23
  • $\begingroup$ Thanks for the reply after some testing and comparison I had to be in object mode and have the smaller bake uvs highlighted in data tab and now it works as expected thanks a lot for your time :) $\endgroup$ – Rcprobot Oct 23 '15 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.