2
$\begingroup$

I made an armature for my character and it moves well until it is applied. I have, again and again, applied all my mirror modifiers so the solutions in "Weird Armature Deformation" have not worked for me. The armature was applied with automatic weights but none of my other models have had this issue before. I have unparented the model and reparented it time and time again but nothing seems to work. Here's the model before: The model before posing

and here is the model after: The model after posing

(Note the arm's weird bend and the legs moving together) Remember, I have tried to use all the solutions given in "Weird Armature Deformation" but nothing has worked yet. Suggestions? Tell me if you need me to upload my model, I would be happy to so that I can fix this issue.

$\endgroup$
  • $\begingroup$ Yes, it would be better to upload your file. If this truly isn't something from your linked answer, then I'd like to know what it is. There are so many possibilities that it's hard to pinpoint the cause from a couple screenshots. $\endgroup$ – Italic_ Oct 18 '15 at 18:41
  • $\begingroup$ The model can be found here: (click here to instantly download the file) $\endgroup$ – WulffHunter Oct 18 '15 at 23:29
  • $\begingroup$ Can't really help you out because there's no rig in this file. Post the file that gave you the problem. I add a rig to that model and I get deformations without any problems. $\endgroup$ – Italic_ Oct 19 '15 at 0:59
  • $\begingroup$ Whoops, I put up the wrong file. Here's the new file (I took down the old one) $\endgroup$ – WulffHunter Oct 21 '15 at 1:33
  • $\begingroup$ I've added an answer based on this new file. $\endgroup$ – Italic_ Oct 22 '15 at 6:30
1
$\begingroup$

There are two problems with your mesh. First, your normals are inside out, which will give you some problems if you try to skin (or anything else, really). Go into edit mode, select all of your mesh, press ctrl-n. A good way to visualize the normals of a mesh is to turn off double-sided lighting. You can do this in the mesh data tab, where you find your vertex groups. Disable the option; if the mesh looks really light, the normals are facing the right way. If it looks dark, the normals are facing inward and need to be reversed. Your screenshots show inverted normals.

Now you can rig the mesh. You already have certain bones set up to deform and not deform, which is good.

First you need to delete your vertex groups on the mesh. This will remove any old weight data on the mesh so you can start clean and fresh. From here, just use automatic weighting. You will certainly need to fine-tune your weights after.

The reason your mesh was deforming so terribly was because your weights were spread out over the whole mesh, not localized to the area with the respective bone. Leg bones were affecting mesh on the opposite side, torso bones had weight up in your arms, etc.

This is a good overview of what weight painting is and how to do it.

https://www.youtube.com/watch?v=S0VS0IVylzg

For documentation on weight painting, see the manual here: https://www.blender.org/manual/rigging/skinning/obdata.html

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.