1
$\begingroup$

I constantly move objects / models in tiny increments without noticing. How can I make it so that I can only move objects deliberately! Through widgets or text entry, no accidental mouse dragging!

$\endgroup$
  • $\begingroup$ Hello! Please don't put that stuff in the title :) $\endgroup$ – VRM Oct 16 '15 at 20:27
  • $\begingroup$ Don't think it's possible to disable this behavior (called "right mouse button transform"), so you might just have to get used to it... :) (will certainly come with time though!) $\endgroup$ – TLousky Oct 16 '15 at 20:41
2
$\begingroup$

In order to not to grab / move objects with RMB, you should change tweak behaviour.

1. Increase the tweak threshold

To do that increase the Tweak Threshold in the User Preferences > Input:

enter image description here

Set it to something like 100 px. This means the mouse will need to move being right-clicked at least 100px in order this event to happen.

enter image description here

2. Turn off the tweak event mapping

In the User Preferences search for "tweak". In the results in 3D View section find and turn off Translate item with type of event mapping Tweak (or change keybinding for it):

enter image description here

$\endgroup$
1
$\begingroup$

Find your outliner. In the outliner are three columns to the far right. The middle of those three columns contains a tiny mouse-pointer glyph. Find your object in the outliner and click that little mouse-pointer glyph. You will find that it toggles on and off. If the glyph is left in the off position, the object will be unresponsive to mouse movements.

$\endgroup$
  • $\begingroup$ This will disable using the 3D manipulator ("widget") too though, but the transform fields work, so might do the trick after all $\endgroup$ – TLousky Oct 16 '15 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.