2
$\begingroup$

I wanted to make a grassfield and made some objects in a group which are emitted in the scene. I added an displacement modifier on the objects so that they look different depending on their global location.

But when the grass objects are emitted the displacement modifier is applied before and isn't changing with position in the viewport or the render. I checked https://www.blender.org/manual/physics/particles/emission.html out but it didn't change anything.

This is also an overall question because it seems to me that modifiers are always applied before emitting. How can i workaround that? (other than copying that object as often as its rendered..)

$\endgroup$
  • 1
    $\begingroup$ The modifiers applied to object will affect to that object, but it will not affect on the way this object is spread by particle system. So Displace modifier will change the geometry of your grass pieces. To change how grass is looking I'd say you should tweak hair with using tools from Particle Edit mode. $\endgroup$ – Mr Zak Oct 16 '15 at 18:44
  • $\begingroup$ You may just have to approximate it by emitting from a group, which are the same mesh in different positions so that the modifiers apply as desired. This will randomize a lot of it quite nicely. $\endgroup$ – VRM Oct 16 '15 at 20:16
  • $\begingroup$ thank you for mentioning the edit mode MrZak , but I am emitting grassobjects, like little bushes and wanted to have it more random.. @NᴏᴠɪᴄᴇIɴDɪsɢᴜɪsᴇ could you please explain this further? It looks odd if I click emit whole group. $\endgroup$ – otto Oct 17 '15 at 12:09
  • $\begingroup$ Select the Random option, and it will select one random mesh from the group for each particle $\endgroup$ – VRM Oct 17 '15 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.